summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2018-07-19 20:26:34 -0400
committerAndrew O'Neill2018-07-19 20:26:34 -0400
commit0ff68ba9363c3ea238fac5e9f3fef326131cc058 (patch)
treee8f1e323ff7c8726578076613cc09e12a2138c91
parentedebc96f35b8be16a15b8cf01c68aee7baf9862b (diff)
downloadaur-0ff68ba9363c3ea238fac5e9f3fef326131cc058.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--python-oci.patch12
3 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5b772e14dcc..03b7b39acaa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-oci
pkgdesc = Python SDK for Oracle Cloud Infrastructure
- pkgver = 1.4.4
+ pkgver = 1.4.5
pkgrel = 1
url = https://github.com/oracle/oci-python-sdk
arch = any
@@ -16,10 +16,10 @@ pkgbase = python-oci
depends = python-pytz
depends = python-requests
depends = python-six
- source = https://github.com/oracle/oci-python-sdk/archive/v1.4.4.tar.gz
+ source = https://github.com/oracle/oci-python-sdk/archive/v1.4.5.tar.gz
source = python-oci.patch
- sha256sums = 7c371b8e443d81d445308443954690a207ba50cf0b3aa8c45604511c20a7d46f
- sha256sums = a79054a7ff2505bee403f91bdd7b4217e8704df0ce19f7eb9c0c249d77abefad
+ sha256sums = dfeb4e384eeec4113a30271f7ff2bfe93c785d988e47dac2d570fab9191c591e
+ sha256sums = 2c701589c9ba55a22288ae7de61886d74cd1b65f9b6ea87c4c1b3ea4e5654856
pkgname = python-oci
diff --git a/PKGBUILD b/PKGBUILD
index 951524f85f61..cca97783c793 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
pkgname=python-oci
_pyname=oci-python-sdk
-pkgver=1.4.4
+pkgver=1.4.5
pkgrel=1
pkgdesc='Python SDK for Oracle Cloud Infrastructure'
arch=('any')
-url="https://github.com/oracle/oci-python-sdk"
+url='https://github.com/oracle/oci-python-sdk'
license=('Apache')
depends=('python' 'python-pyjwt' 'python-dateutil' 'python-certifi' 'python-cryptography' 'python-idna' 'python-pyopenssl' 'python-pytz' 'python-requests' 'python-six')
makedepends=('python-setuptools')
source=("${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('7c371b8e443d81d445308443954690a207ba50cf0b3aa8c45604511c20a7d46f'
- 'a79054a7ff2505bee403f91bdd7b4217e8704df0ce19f7eb9c0c249d77abefad')
+sha256sums=('dfeb4e384eeec4113a30271f7ff2bfe93c785d988e47dac2d570fab9191c591e'
+ '2c701589c9ba55a22288ae7de61886d74cd1b65f9b6ea87c4c1b3ea4e5654856')
prepare() {
cd "${_pyname}-${pkgver}"
diff --git a/python-oci.patch b/python-oci.patch
index 443fdc414fdc..25c4d38eb8fb 100644
--- a/python-oci.patch
+++ b/python-oci.patch
@@ -1,14 +1,13 @@
-diff -rupN oci-python-sdk-1.4.4/setup.py oci-python-sdk-1.4.4b/setup.py
---- oci-python-sdk-1.4.4/setup.py 2018-06-28 18:07:21.000000000 -0400
-+++ oci-python-sdk-1.4.4b/setup.py 2018-07-01 13:32:34.083089009 -0400
-@@ -30,15 +30,14 @@ with open_relative("README.rst") as f:
+diff -rupN oci-python-sdk-1.4.5/setup.py oci-python-sdk-1.4.5b/setup.py
+--- oci-python-sdk-1.4.5/setup.py 2018-07-19 20:20:27.120901893 -0400
++++ oci-python-sdk-1.4.5b/setup.py 2018-07-19 20:21:26.071228439 -0400
+@@ -30,14 +30,13 @@ with open_relative("README.rst") as f:
requires = [
"certifi",
- "configparser==3.5.0",
-- "cryptography==2.1.3",
+- "cryptography>=2.1.3,<=2.2.2",
- "idna>=2.5,<2.7",
-- "PyJWT==1.5.3",
- "pyOpenSSL<=17.4.0",
- "python-dateutil>=2.5.3,<=2.7.3",
- "pytz>=2016.10",
@@ -16,7 +15,6 @@ diff -rupN oci-python-sdk-1.4.4/setup.py oci-python-sdk-1.4.4b/setup.py
- "six==1.11.0",
+ "cryptography",
+ "idna",
-+ "PyJWT",
+ "pyOpenSSL",
+ "python-dateutil",
+ "pytz",