summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2020-02-01 22:09:24 -0500
committerAndrew O'Neill2020-02-01 22:09:24 -0500
commitbfd5f52908bf30b411729d3d121742bdd34bc57b (patch)
tree4c3cfcd37a3c80f32a5d8371514a66692088346f
parent266b60150f1a429c0c989fd75e38a09d0712fa3e (diff)
downloadaur-bfd5f52908bf30b411729d3d121742bdd34bc57b.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--python-oci.patch8
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be73b33708ff..37cd9c6e6a96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-oci
pkgdesc = Python SDK for Oracle Cloud Infrastructure
- pkgver = 2.9.0
+ pkgver = 2.10.2
pkgrel = 1
url = https://github.com/oracle/oci-python-sdk
arch = x86_64
@@ -12,10 +12,10 @@ pkgbase = python-oci
depends = python-cryptography
depends = python-pyopenssl
depends = python-pytz
- source = python-oci-2.9.0.tar.gz::https://github.com/oracle/oci-python-sdk/archive/v2.9.0.tar.gz
+ source = python-oci-2.10.2.tar.gz::https://github.com/oracle/oci-python-sdk/archive/v2.10.2.tar.gz
source = python-oci.patch
- sha256sums = e3750791fae80717c47df92202720b025b4ea7256b9f23eb298abe2d54b6286a
- sha256sums = 429f3d5439d329b9a361181930e62897b8d30fef12f752ea37292451fafbc927
+ sha256sums = af302792aa8411b55dbfb9d78a9b6a3c5aee4e0109f64c296f2a8de0d1f36b54
+ sha256sums = 29931b3ef482ca85b6fac08d24e3fad8f41c2a5ea8b44de46a822bab47d2e1fd
pkgname = python-oci
diff --git a/PKGBUILD b/PKGBUILD
index 9a5253d8cd38..8945265a3057 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-oci
_pyname=oci-python-sdk
-pkgver=2.9.0
+pkgver=2.10.2
pkgrel=1
pkgdesc='Python SDK for Oracle Cloud Infrastructure'
arch=('x86_64')
@@ -12,8 +12,8 @@ depends=('python' 'python-dateutil' 'python-certifi' 'python-cryptography' 'pyth
makedepends=('python-setuptools')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('e3750791fae80717c47df92202720b025b4ea7256b9f23eb298abe2d54b6286a'
- '429f3d5439d329b9a361181930e62897b8d30fef12f752ea37292451fafbc927')
+sha256sums=('af302792aa8411b55dbfb9d78a9b6a3c5aee4e0109f64c296f2a8de0d1f36b54'
+ '29931b3ef482ca85b6fac08d24e3fad8f41c2a5ea8b44de46a822bab47d2e1fd')
prepare() {
cd "${_pyname}-${pkgver}"
diff --git a/python-oci.patch b/python-oci.patch
index 98da6e21949d..486339fdf02f 100644
--- a/python-oci.patch
+++ b/python-oci.patch
@@ -1,12 +1,12 @@
-diff -rupN oci-python-sdk-2.9.0/setup.py oci-python-sdk-2.9.0b/setup.py
---- oci-python-sdk-2.9.0/setup.py 2020-01-08 17:14:03.000000000 -0500
-+++ oci-python-sdk-2.9.0b/setup.py 2020-01-11 11:17:04.711305878 -0500
+diff -rupN oci-python-sdk-2.10.2/setup.py oci-python-sdk-2.10.2b/setup.py
+--- oci-python-sdk-2.10.2/setup.py 2020-01-28 17:38:37.000000000 -0500
++++ oci-python-sdk-2.10.2b/setup.py 2020-02-01 21:59:24.881533777 -0500
@@ -30,11 +30,10 @@ with open_relative("README.rst") as f:
requires = [
"certifi",
- "configparser>=3.5.0b1",
-- "cryptography>=2.1.4",
+- "cryptography==2.8",
- "pyOpenSSL>=17.5.0",
- "python-dateutil>=2.5.3,<3.0.0",
- "pytz>=2016.10",