summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-06 00:14:26 +1100
committerPumpkinCheshire2020-11-06 00:14:26 +1100
commit9f33036c529d043fc9ac812db8b54542da1d7ac0 (patch)
tree4363da54d8c8afd7b36f51f98a3d4bba6e940409
parenta732d9b76a172587c5afe10f6fbdf7ad0aa68d09 (diff)
downloadaur-9f33036c529d043fc9ac812db8b54542da1d7ac0.tar.gz
bump version to 5.2.0, remove python2 split
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD47
2 files changed, 33 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a49f9c7774ec..2d6cccc9582a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
-# Generated by mksrcinfo v8
-# Thu Jun 22 16:32:57 UTC 2017
pkgbase = python-oct2py
pkgdesc = Python to GNU Octave bridge.
- pkgver = 4.0.6
+ pkgver = 5.2.0
pkgrel = 1
url = http://github.com/blink1073/oct2py
arch = any
license = MIT
makedepends = python-setuptools
- makedepends = python2-setuptools
- makedepends = jupyter-octave_kernel
- source = https://github.com/blink1073/oct2py/archive/v4.0.6.tar.gz
- md5sums = 00d4a5cd3ae5d5409d6a4b0c8f286211
-
-pkgname = python-oct2py
depends = python-scipy
+ depends = python-numpy
depends = jupyter-octave_kernel
+ depends = gnuplot
+ optdepends = python-pytest: for test use
+ optdepends = python-pandas: for test use
+ optdepends = jupyter-nbconvert: for test use
+ optdepends = python-sphinx: documentation support
+ optdepends = python-sphinx-bootstrap-theme
+ optdepends = python-numpydoc: documentation support
+ source = https://files.pythonhosted.org/packages/source/o/oct2py/oct2py-5.2.0.tar.gz
+ sha256sums = 7e7f03724d60745b6ff49760027712a5ae22ed3c67f8d4560ba8a80c2ebdfaf0
-pkgname = python2-oct2py
- depends = python2-scipy
- depends = octave
+pkgname = python-oct2py
diff --git a/PKGBUILD b/PKGBUILD
index c1394f27bca7..082477d67f76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,34 @@
+# Maintainer: PumpkinCheshire <sollyonzou@gmail.com>
# Contributor: Ishan Arora <ishanarora@gmail.com>
-pkbase=python-oct2py
-pkgname=('python-oct2py' 'python2-oct2py')
-pkgver=4.0.6
+_name=oct2py
+pkgname=python-oct2py
+pkgver=5.2.0
pkgrel=1
pkgdesc="Python to GNU Octave bridge."
arch=('any')
url="http://github.com/blink1073/oct2py"
license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools' 'jupyter-octave_kernel')
-source=("https://github.com/blink1073/oct2py/archive/v${pkgver}.tar.gz")
-md5sums=('00d4a5cd3ae5d5409d6a4b0c8f286211')
+depends=('python-scipy' 'python-numpy' 'jupyter-octave_kernel' 'gnuplot')
+optdepends=('python-pytest: for test use'
+ 'python-pandas: for test use'
+ 'jupyter-nbconvert: for test use'
+ 'python-sphinx: documentation support'
+ 'python-sphinx-bootstrap-theme'
+ 'python-numpydoc: documentation support')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('7e7f03724d60745b6ff49760027712a5ae22ed3c67f8d4560ba8a80c2ebdfaf0')
-build() {
- cp -r "${srcdir}"/oct2py-$pkgver "${srcdir}"/oct2py-$pkgver-py2
-
- cd "${srcdir}"/oct2py-$pkgver
- python setup.py build
-
- cd "${srcdir}"/oct2py-$pkgver-py2
- python2 setup.py build
-}
-
-package_python-oct2py() {
- depends=('python-scipy' 'jupyter-octave_kernel')
- cd "${srcdir}"/oct2py-$pkgver
- python setup.py install --root="${pkgdir}" --optimize=1
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
}
-package_python2-oct2py() {
- depends=('python2-scipy' 'octave')
-
- cd "${srcdir}"/oct2py-$pkgver-py2
- python2 setup.py install --root="${pkgdir}" --optimize=1
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/python-$_name/LICENSE"
}
-