summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-12-04 09:20:30 +1100
committerPumpkinCheshire2020-12-04 09:20:30 +1100
commita1b87dcea33115d8ff6281261d7e946f40d34c28 (patch)
treede4c9016037545d03da3aa92f39047c7966a5367
parent9f33036c529d043fc9ac812db8b54542da1d7ac0 (diff)
downloadaur-a1b87dcea33115d8ff6281261d7e946f40d34c28.tar.gz
bump for python3.9
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d6cccc9582a..d4ab5a506397 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-oct2py
pkgdesc = Python to GNU Octave bridge.
pkgver = 5.2.0
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/blink1073/oct2py
arch = any
license = MIT
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 082477d67f76..67dfe6099b1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,29 @@
_name=oct2py
pkgname=python-oct2py
pkgver=5.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python to GNU Octave bridge."
arch=('any')
url="http://github.com/blink1073/oct2py"
license=('MIT')
depends=('python-scipy' 'python-numpy' 'jupyter-octave_kernel' 'gnuplot')
optdepends=('python-pytest: for test use'
- 'python-pandas: for test use'
- 'jupyter-nbconvert: for test use'
- 'python-sphinx: documentation support'
- 'python-sphinx-bootstrap-theme'
- 'python-numpydoc: documentation support')
+ 'python-pandas: for test use'
+ 'jupyter-nbconvert: for test use'
+ 'python-sphinx: documentation support'
+ 'python-sphinx-bootstrap-theme'
+ 'python-numpydoc: documentation support')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
sha256sums=('7e7f03724d60745b6ff49760027712a5ae22ed3c67f8d4560ba8a80c2ebdfaf0')
-
build() {
cd "$srcdir/$_name-$pkgver"
python setup.py build
}
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/python-$_name/LICENSE"
}
-