summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Parra2017-08-12 18:43:30 +0200
committerEduardo Parra2017-08-12 18:43:30 +0200
commitd1ba73d59aae3661c9cab6c90989c3e9c1e81929 (patch)
treeeee2f5bf287ea10bb6381d35208278264ddf39ff
downloadaur-d1ba73d59aae3661c9cab6c90989c3e9c1e81929.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..111e2df1abaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-odfpy
+ pkgdesc = Python API and tools to manipulate OpenDocument files
+ pkgver = 1.3.5
+ pkgrel = 1
+ url = https://github.com/eea/odfpy
+ arch = i686
+ arch = x86_64
+ license = Apache-2.0
+ depends = python
+ conflicts = odfpy
+ conflicts = python-odfpy
+ conflicts = python2-odfpy
+ conflicts = python-all-odfpy
+ source = https://github.com/eea/odfpy/archive/release-1.3.5.tar.gz
+ md5sums = 8f800938b5dcac5687161834551e518e
+
+pkgname = python-odfpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d988fedc858f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Eduardo Parra Mazuecos <eduparra90@gmail.com>
+
+# I maintain this on github, feel free to submit a pull request to
+# https://github.com/soker90/paquetes-archinux.git
+pkgname=python-odfpy
+pkgver=1.3.5
+pkgrel=1
+pkgdesc="Python API and tools to manipulate OpenDocument files"
+arch=('i686' 'x86_64')
+url="https://github.com/eea/odfpy"
+license=('Apache-2.0')
+depends=('python')
+conflicts=('odfpy' 'python-odfpy' 'python2-odfpy' 'python-all-odfpy')
+source=("https://github.com/eea/odfpy/archive/release-$pkgver.tar.gz")
+md5sums=('8f800938b5dcac5687161834551e518e')
+
+package() {
+ cd "$srcdir/odfpy-release-${pkgver}"
+ python setup.py install --root=${pkgdir}
+}