summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2018-11-27 22:24:19 +0000
committerGrey Christoforo2018-11-27 22:24:19 +0000
commit6248b89467748b764a2f5ccd4c856bea93a465d9 (patch)
treeebb81540a9abb3d314d91cfea99cb40d26713416
downloadaur-6248b89467748b764a2f5ccd4c856bea93a465d9.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1357c1ff2734
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-offshoot-git
+ pkgdesc = Modern, elegant, minimalistic but powerful plugin system for Python 3.5+.
+ pkgver = r9.7906a95
+ pkgrel = 1
+ url = https://github.com/greyltc/offshoot
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-yaml
+ source = git://github.com/greyltc/offshoot.git
+ md5sums = SKIP
+
+pkgname = python-offshoot-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d798d6c686a2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+offshoot/
+pkg/
+src/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9229701bf1f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=python-offshoot-git
+_module='offshoot'
+pkgver=r9.7906a95
+pkgrel=1
+pkgdesc="Modern, elegant, minimalistic but powerful plugin system for Python 3.5+."
+url="https://github.com/greyltc/offshoot"
+depends=(python python-yaml)
+makedepends=(python-setuptools)
+license=('MIT')
+arch=('any')
+source=("git://github.com/greyltc/offshoot.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_module"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_module}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+