summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Rebischke2016-02-11 18:11:13 +0100
committerChristian Rebischke2016-02-11 18:11:13 +0100
commit98b3d1c26dbb852d760bb9efa21fd1b7998f0d72 (patch)
tree9e013c824a8727a5765cadb0f5f2f992bdf0f34c
parent88cf155248f91de6bc8f7b992116a34c95febc9e (diff)
downloadaur-98b3d1c26dbb852d760bb9efa21fd1b7998f0d72.tar.gz
fixed shebang line of python files
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de285ca3d19f..41959a8593d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Feb 10 23:58:22 UTC 2016
+# Thu Feb 11 17:09:40 UTC 2016
pkgbase = python2-oletools
pkgdesc = Python tools to analyze security characteristics of MS Office and OLE files
pkgver = 0.42
diff --git a/PKGBUILD b/PKGBUILD
index 8e660832872c..17762daddef9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,6 +19,14 @@ package() {
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
cp ${_pyname}/doc/* "${pkgdir}/usr/share/doc/${pkgname}"
+ # fixing shebang line
+ cd "${pkgdir}/usr/lib/python2.7/site-packages/oletools/"
+ for file in *.py; do
+ if [ "$file" != "__init__.py" ]; then
+ sed -i '1s/python/python2/' "$file"
+ fi
+ done
+
}
# vim:set noet sts=4 sw=4 ts=4 tw=76: