summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrad Ackerman2019-06-16 22:07:26 -0400
committerBrad Ackerman2019-06-16 22:07:26 -0400
commitaa62c4826bdfc7b49d79d7721c14a338b394692b (patch)
treeea5ccdeaf2999bde14d26051eb4627a0d6a546e5
parent75162c5db87a7362e12155fcb811f4eeb6230ffb (diff)
downloadaur-aa62c4826bdfc7b49d79d7721c14a338b394692b.tar.gz
Copy python2 package and convert to python3.
-rw-r--r--.SRCINFO16
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD33
3 files changed, 30 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6a8a636b745..714edf24fbee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
-pkgbase = python2-oletools
+pkgbase = python-oletools
pkgdesc = Python tools to analyze security characteristics of MS Office and OLE files
- pkgver = 0.51
+ pkgver = 0.54.2
pkgrel = 1
url = https://github.com/decalage2/oletools
arch = any
license = BSD
- depends = python2
- source = oletools-0.51.tar.gz::https://github.com/decalage2/oletools/archive/v0.51.tar.gz
- sha512sums = 030da6195af1554ca8725eb41f7c0974aa26028340d296d165f7797179bc6b076e31a5cc061addc6b357115ed62976bcf7fe9369c67d7b6629baa17ff12f535d
+ depends = python
+ depends = python-colorclass
+ depends = python-easygui
+ depends = python-pyparsing
+ depends = python-msoffcrypto-tool
+ source = https://github.com/decalage2/oletools/releases/download/v0.54.2b/oletools-0.54.2.tar.gz
+ sha512sums = 8399ff65379f63d647e0a58660a77eee22436df9c6cc4baca413ed762750f9d89c8c7d326a94a42a69c357d1abd33b2ddf9cb5b0595a6df9c5606ed461215b06
-pkgname = python2-oletools
+pkgname = python-oletools
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..ce40c725a87e
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,2 @@
+.SRCINFO: PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 1e9170f9ce1d..f7c1ea10e207 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,33 @@
-# Maintainer: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
+# Maintainer: Brad Ackerman <brad[at]facefault.org>
+# Contributor: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
_pyname=oletools
-pkgname=python2-oletools
-pkgver=0.51
+pkgname=python-oletools
+pkgver=0.54.2
pkgrel=1
pkgdesc="Python tools to analyze security characteristics of MS Office and OLE files"
-depends=('python2')
+depends=('python'
+ 'python-colorclass'
+ 'python-easygui'
+ 'python-pyparsing'
+ 'python-msoffcrypto-tool')
arch=('any')
url="https://github.com/decalage2/oletools"
license=('BSD')
-source=("${_pyname}-${pkgver}.tar.gz::https://github.com/decalage2/oletools/archive/v${pkgver}.tar.gz")
-sha512sums=('030da6195af1554ca8725eb41f7c0974aa26028340d296d165f7797179bc6b076e31a5cc061addc6b357115ed62976bcf7fe9369c67d7b6629baa17ff12f535d')
+source=("https://github.com/decalage2/oletools/releases/download/v${pkgver}b/${_pyname}-${pkgver}.tar.gz")
+sha512sums=('8399ff65379f63d647e0a58660a77eee22436df9c6cc4baca413ed762750f9d89c8c7d326a94a42a69c357d1abd33b2ddf9cb5b0595a6df9c5606ed461215b06')
+
+# Some checks failing; will investigate. -BA 20190616
+# check() {
+# cd "${srcdir}/${_pyname}-${pkgver}"
+# python3 setup.py test
+# }
package() {
cd "${srcdir}/${_pyname}-${pkgver}"
- python2 setup.py install -O1 --root="${pkgdir}"
+ python3 setup.py install -O1 --root="${pkgdir}"
install -Dm 644 ${_pyname}/LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
cp ${_pyname}/doc/* "${pkgdir}/usr/share/doc/${pkgname}"
-
- # fixing shebang line
- cd "${pkgdir}/usr/lib/python2.7/site-packages/oletools/"
- for file in *.py; do
- if [ "${file}" != "__init__.py" ]; then
- sed -i '1s/python/python2/' "${file}"
- fi
- done
}
# vim:set et sw=2 ts=2 tw=79: