summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Rebischke2016-11-13 21:45:29 +0100
committerChristian Rebischke2016-11-13 21:45:29 +0100
commitdc7512ff7d33a1a70e6e4a883e04b33147a8c490 (patch)
tree70894b748986d92804a5f5a6717eb02453574580
parentb89a99e85c326434878a215a1568a7fcd90b9e4e (diff)
downloadaur-dc7512ff7d33a1a70e6e4a883e04b33147a8c490.tar.gz
made src unique
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5e1c83149b4..71f0e72b3217 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
-# Generated by mksrcinfo v8
-# Thu Feb 11 19:59:36 UTC 2016
pkgbase = python2-oletools
pkgdesc = Python tools to analyze security characteristics of MS Office and OLE files
pkgver = 0.42
- pkgrel = 2
+ pkgrel = 3
url = https://bitbucket.org/decalage/oletools
arch = any
license = BSD
depends = python2
- source = https://bitbucket.org/decalage/oletools/downloads/oletools-0.42.tar.gz
+ source = oletools-0.42.tar.gz::https://bitbucket.org/decalage/oletools/downloads/oletools-0.42.tar.gz
sha512sums = d70d8c0dde63b8e69eafbbcda60928e6e45b306f87562a64b3b1fad94f729a04b210b2f6634e030ed69e1dd3cab61a365c875021f0e9e01f6a862f3533fadbae
pkgname = python2-oletools
diff --git a/PKGBUILD b/PKGBUILD
index 997689dc022b..7f341d6acc21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
_pyname=oletools
pkgname=python2-oletools
pkgver=0.42
-pkgrel=2
+pkgrel=3
pkgdesc="Python tools to analyze security characteristics of MS Office and OLE files"
depends=('python2')
arch=('any')
url="https://bitbucket.org/decalage/oletools"
license=('BSD')
-source=("https://bitbucket.org/decalage/oletools/downloads/$_pyname-$pkgver.tar.gz")
+source=("${_pyname}-${pkgver}.tar.gz::https://bitbucket.org/decalage/oletools/downloads/${_pyname}-${pkgver}.tar.gz")
sha512sums=('d70d8c0dde63b8e69eafbbcda60928e6e45b306f87562a64b3b1fad94f729a04b210b2f6634e030ed69e1dd3cab61a365c875021f0e9e01f6a862f3533fadbae')
package() {
- cd "$srcdir/$_pyname-$pkgver"
- python2 setup.py install -O1 --root=$pkgdir
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python2 setup.py install -O1 --root="${pkgdir}"
install -Dm 644 ${_pyname}/LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
cp ${_pyname}/doc/* "${pkgdir}/usr/share/doc/${pkgname}"
@@ -21,8 +21,8 @@ package() {
# fixing shebang line
cd "${pkgdir}/usr/lib/python2.7/site-packages/oletools/"
for file in *.py; do
- if [ "$file" != "__init__.py" ]; then
- sed -i '1s/python/python2/' "$file"
+ if [ "${file}" != "__init__.py" ]; then
+ sed -i '1s/python/python2/' "${file}"
fi
done
}