summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorworkonfire2021-05-06 12:13:46 +0200
committerworkonfire2021-05-06 12:13:46 +0200
commit036253d45d3db8d6f6d2fbdde5b02f7601bd32ab (patch)
treec70194f22c1e8c4ae8ae1472e40c639c1f5310a3
downloadaur-036253d45d3db8d6f6d2fbdde5b02f7601bd32ab.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD26
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7f0be6592cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-onigurumacffi
+ pkgdesc = Python cffi bindings for the oniguruma regex engine
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/asottile/onigurumacffi
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = oniguruma
+ depends = python-cffi
+ source = https://github.com/asottile/onigurumacffi/archive/v1.1.0.tar.gz
+ md5sums = 191a556c60f4d93a42127292b16e2f98
+
+pkgname = python-onigurumacffi
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b1d7bac67692
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Tar files
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.zst
+
+# Makepkg trash
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..780a3e1842fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: workonfire <kolucki62@gmail.com>
+
+_pkgname=onigurumacffi
+pkgname=python-$_pkgname
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Python cffi bindings for the oniguruma regex engine"
+arch=('x86_64')
+url="https://github.com/asottile/onigurumacffi"
+license=('MIT')
+depends=('oniguruma' 'python-cffi')
+makedepends=('python-setuptools')
+source=("$url/archive/v$pkgver.tar.gz")
+md5sums=('191a556c60f4d93a42127292b16e2f98')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+