summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Sulfrian2020-03-08 23:43:09 +0100
committerAlexander Sulfrian2020-03-09 02:01:42 +0100
commit327a5b9c5ada0d5a83c34b1b388dff33a9339a3f (patch)
tree2a5458ee1fb507d1aaeb191ad54f6a1a84ea2490
parentd69e74f1d115aa2823a2130450243b169ba04750 (diff)
downloadaur-327a5b9c5ada0d5a83c34b1b388dff33a9339a3f.tar.gz
Bump version, improve packaging
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD31
4 files changed, 56 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8d65343f8e9..4946e596f57b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,19 @@
pkgbase = python-onkyo-eiscp
pkgdesc = Control Onkyo receivers over ethernet.
- pkgver = 1.2.4
+ pkgver = 1.2.7
pkgrel = 1
url = https://github.com/miracle2k/onkyo-eiscp
arch = any
license = MIT
- makedepends = python-pip
- depends = python
- provides = onkyo
+ makedepends = python
+ makedepends = python-setuptools
+ source = https://pypi.python.org/packages/source/o/onkyo-eiscp/onkyo-eiscp-1.2.7.tar.gz
+ source = LICENSE
+ sha512sums = 0fe8f23762d49b3b2c45ef24b94345d9a342cf04b2fa55538abf4ea21a6039011c0ade945f7432555ec948811ab521bb6a611909e19163e0e0c806bf87604635
+ sha512sums = add0fe8ba0782245d13ab8765939a9cc98dd4776b119388dc18fd10d609f2b81ddd7191b72d9ff26f412d564434515cbaaf47a1761ae7b41075f8bbcc53e5158
pkgname = python-onkyo-eiscp
+ depends = python
+ depends = python-docopt
+ depends = python-netifaces
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0cd1c4c079c3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tar.gz
+*.pkg.tar.xz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..51a92f588cd8
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License
+
+Copyright (c) 2010 Will Nowak
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index f3d9cad9a4c9..60d83fc28624 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,30 @@
-# Maintainer: Sandro Kalbermatter <info.kalsan [ät-symbol] valaiscom.ch>
+# Maintainer: Alexander Sulfrian <asulfrian@zedat.fu-berlin.de>
pkgname=python-onkyo-eiscp
-pkgver=1.2.4
+_pkgname=onkyo-eiscp
+pkgver=1.2.7
pkgrel=1
pkgdesc="Control Onkyo receivers over ethernet."
arch=('any')
-url="https://github.com/miracle2k/onkyo-eiscp"
+url='https://github.com/miracle2k/onkyo-eiscp'
license=('MIT')
-depends=('python')
-provides=(onkyo)
-makedepends=('python-pip')
+makedepends=('python' 'python-setuptools')
options=()
-source=()
-md5sums=()
+source=("https://pypi.python.org/packages/source/o/onkyo-eiscp/onkyo-eiscp-$pkgver.tar.gz"
+ LICENSE)
+sha512sums=('0fe8f23762d49b3b2c45ef24b94345d9a342cf04b2fa55538abf4ea21a6039011c0ade945f7432555ec948811ab521bb6a611909e19163e0e0c806bf87604635'
+ 'add0fe8ba0782245d13ab8765939a9cc98dd4776b119388dc18fd10d609f2b81ddd7191b72d9ff26f412d564434515cbaaf47a1761ae7b41075f8bbcc53e5158')
-package() {
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps onkyo-eiscp
+build() {
+ cd "$srcdir"/onkyo-eiscp-$pkgver
+ python setup.py build
+}
+
+package_python-onkyo-eiscp() {
+ depends=('python' 'python-docopt' 'python-netifaces')
+
+ cd "$srcdir"/onkyo-eiscp-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -D -m644 "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}