summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-01-30 22:18:44 +0800
committerlilac2021-01-30 22:18:44 +0800
commit1f842d1cd49bcb539f440540f20b0989f40a8328 (patch)
treebf062fb4fe742568548783a03b7ea41583ebb1d9
parentf18e5940f966fcf8352a0b8a917a2343ba696c24 (diff)
downloadaur-1f842d1cd49bcb539f440540f20b0989f40a8328.tar.gz
[lilac] updated to 1.8.1-2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD37
2 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b45ad5a0bd24..20907d2fbf93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-onnx
pkgdesc = Open Neural Network Exchange
- pkgver = 1.8.0
- pkgrel = 1
+ pkgver = 1.8.1
+ pkgrel = 2
url = https://onnx.ai
arch = x86_64
license = MIT
@@ -12,6 +12,7 @@ pkgbase = python-onnx
makedepends = cmake
makedepends = git
makedepends = python-setuptools
+ makedepends = python-pip
depends = protobuf
depends = python-protobuf
depends = python-numpy
@@ -20,7 +21,7 @@ pkgbase = python-onnx
optdepends = mxnet
optdepends = python-pytorch
optdepends = python-tensorflow
- source = python-onnx::git+https://github.com/onnx/onnx.git#tag=v1.8.0
+ source = python-onnx::git+https://github.com/onnx/onnx.git#tag=v1.8.1
sha512sums = SKIP
pkgname = python-onnx
diff --git a/PKGBUILD b/PKGBUILD
index 2f5fd5b8d5b0..9c806afa2a50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,36 @@
# Maintainer: Butui Hu <hot123tea123@gmail.com>
pkgname=python-onnx
-pkgver=1.8.0
-pkgrel=1
+pkgver=1.8.1
+pkgrel=2
pkgdesc='Open Neural Network Exchange'
arch=('x86_64')
url='https://onnx.ai'
license=('MIT')
depends=(
- 'protobuf'
- 'python-protobuf'
- 'python-numpy'
- 'python-six'
- 'python-typing_extensions'
+ protobuf
+ python-protobuf
+ python-numpy
+ python-six
+ python-typing_extensions
)
makedepends=(
- 'cmake'
- 'git'
- 'python-setuptools'
+ cmake
+ git
+ python-setuptools
+ python-pip
)
checkdepends=(
- 'python-nbval'
- 'python-nose'
- 'python-pytest'
- 'python-scipy'
+ python-nbval
+ python-nose
+ python-pytest
+ python-scipy
${optdepends[@]}
)
optdepends=(
- 'mxnet'
- 'python-pytorch'
- 'python-tensorflow'
+ mxnet
+ python-pytorch
+ python-tensorflow
)
source=("${pkgname}::git+https://github.com/onnx/onnx.git#tag=v${pkgver}")
sha512sums=('SKIP')
@@ -41,8 +42,6 @@ get_pyver() {
prepare() {
cd "${srcdir}/${pkgname}"
git submodule update --init --recursive
- # fix build with protobuf 3.11, see https://github.com/onnx/onnx/pull/2482/files
- sed -i 's/${ONNX_DLLEXPORT_STR}${CMAKE_CURRENT_BINARY_DIR})/${CMAKE_CURRENT_BINARY_DIR})/' "${srcdir}/${pkgname}/CMakeLists.txt"
}
build() {