summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2019-07-09 20:39:26 +0800
committerlilac2019-07-09 20:39:26 +0800
commitc53d7b574a66b044730bfd00b8caa644d4246333 (patch)
treec8e826b612b698c2ebf7e4966757e4eaa746559b
parent031aa408ada648cf1ad0dc2323ead24100a7d0f7 (diff)
downloadaur-c53d7b574a66b044730bfd00b8caa644d4246333.tar.gz
update by lilac
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--no-typing.patch31
3 files changed, 45 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 208262be917c..e551ecc22ee4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-onnx
pkgdesc = Open Neural Network Exchange
pkgver = 1.5.0
- pkgrel = 2
+ pkgrel = 4
url = https://onnx.ai
arch = x86_64
license = MIT
@@ -13,13 +13,17 @@ pkgbase = python-onnx
makedepends = git
makedepends = python-setuptools
depends = protobuf
+ depends = python-protobuf
depends = python-numpy
depends = python-six
+ depends = python-typing_extensions
optdepends = mxnet
optdepends = python-pytorch
optdepends = python-tensorflow
source = python-onnx::git+https://github.com/onnx/onnx.git#tag=v1.5.0
+ source = no-typing.patch
sha512sums = SKIP
+ sha512sums = 902df9eb236f69c47d838813687fa8f22fee0efeea6a831a9ed0c78c8f52d93e31c57689141c92a8eb1a4c3592a8e01162c857b72766543a9e1a8f43b1b0efe7
pkgname = python-onnx
diff --git a/PKGBUILD b/PKGBUILD
index bc322d4d79f4..9033f5387706 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
pkgname=python-onnx
pkgver=1.5.0
-pkgrel=2
+pkgrel=4
pkgdesc='Open Neural Network Exchange'
arch=('x86_64')
url='https://onnx.ai'
license=('MIT')
depends=(
'protobuf'
+ 'python-protobuf'
'python-numpy'
'python-six'
+ 'python-typing_extensions'
)
makedepends=(
'cmake'
@@ -29,12 +31,15 @@ optdepends=(
'python-pytorch'
'python-tensorflow'
)
-source=("${pkgname}::git+https://github.com/onnx/onnx.git#tag=v${pkgver}")
-sha512sums=('SKIP')
+source=("${pkgname}::git+https://github.com/onnx/onnx.git#tag=v${pkgver}"
+ 'no-typing.patch')
+sha512sums=('SKIP'
+ '902df9eb236f69c47d838813687fa8f22fee0efeea6a831a9ed0c78c8f52d93e31c57689141c92a8eb1a4c3592a8e01162c857b72766543a9e1a8f43b1b0efe7')
prepare() {
cd "${srcdir}/${pkgname}"
git submodule update --init --recursive
+ patch -Np1 -i ../no-typing.patch
}
build() {
@@ -44,7 +49,7 @@ build() {
check() {
cd "${srcdir}/${pkgname}"
- pytest -v
+ PYTHONPATH=$(pwd)/build/lib.linux-$CARCH-3.7 pytest -v
}
package() {
diff --git a/no-typing.patch b/no-typing.patch
new file mode 100644
index 000000000000..917500939e74
--- /dev/null
+++ b/no-typing.patch
@@ -0,0 +1,31 @@
+From 3eddf9db09ffef24474f6178b68129ce68dad041 Mon Sep 17 00:00:00 2001
+From: Chih-Hsuan Yen <yan12125@gmail.com>
+Date: Tue, 2 Jul 2019 15:18:58 +0800
+Subject: [PATCH] typing is not needed since Python 3.5 as it's built-in
+
+---
+ setup.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 882b22ac0b..8b23efa932 100644
+--- a/setup.py
++++ b/setup.py
+@@ -286,7 +286,7 @@ def run(self):
+ 'protobuf',
+ 'numpy',
+ 'six',
+- 'typing>=3.6.4',
++ 'typing>=3.6.4 ; python_version<"3.5"',
+ 'typing-extensions>=3.6.2.1',
+ ])
+
+@@ -298,7 +298,7 @@ def run(self):
+ tests_require.append('pytest')
+ tests_require.append('nbval')
+ tests_require.append('tabulate')
+-tests_require.append('typing')
++tests_require.append('typing ; python_version<"3.5"')
+ tests_require.append('typing-extensions')
+
+ if sys.version_info[0] == 3: