summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2022-05-05 11:33:52 +0800
committerChih-Hsuan Yen2022-05-05 11:33:52 +0800
commit0f11450040dc12c1fadb783d5ecd78080a0fa992 (patch)
tree06019aaed3240cca3e2fd2efff9304a316cc23e6
parenta3e6d9217157f785412229085d39cc8189ffe0c0 (diff)
downloadaur-0f11450040dc12c1fadb783d5ecd78080a0fa992.tar.gz
update to 0.2.7 and disable non-working tests
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b986de539c13..1d6689e1d584 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = python-onnxoptimizer
pkgdesc = ONNX model optimizer
- pkgver = 0.2.6
+ pkgver = 0.2.7
pkgrel = 1
url = https://github.com/onnx/optimizer
arch = x86_64
license = MIT
checkdepends = python-pytest
checkdepends = python-nbval
- checkdepends = python-torchvision
checkdepends = python-onnxruntime
makedepends = python-setuptools
makedepends = cmake
@@ -15,7 +14,7 @@ pkgbase = python-onnxoptimizer
makedepends = git
depends = python
depends = python-onnx
- source = onnx-optimizer::git+https://github.com/onnx/optimizer.git#tag=v0.2.6
+ source = onnx-optimizer::git+https://github.com/onnx/optimizer.git#tag=v0.2.7
source = git+https://github.com/onnx/onnx.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c2a91d4da6c6..d7f1e4938163 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
pkgname=python-onnxoptimizer
-pkgver=0.2.6
+pkgver=0.2.7
pkgdesc='ONNX model optimizer'
pkgrel=1
arch=(x86_64)
@@ -9,7 +9,11 @@ url='https://github.com/onnx/optimizer'
license=(MIT)
depends=(python python-onnx)
makedepends=(python-setuptools cmake pybind11 git)
-checkdepends=(python-pytest python-nbval python-torchvision python-onnxruntime)
+checkdepends=(python-pytest python-nbval python-onnxruntime
+ # Disable tests using torchvision for now due to a pytorch bug
+ # https://bugs.archlinux.org/task/74593
+ # python-torchvision
+)
source=("onnx-optimizer::git+https://github.com/onnx/optimizer.git#tag=v$pkgver"
"git+https://github.com/onnx/onnx.git")
sha256sums=('SKIP'
@@ -18,6 +22,8 @@ sha256sums=('SKIP'
prepare() {
cd onnx-optimizer
sed -i '/pytest-runner/d' setup.py
+ # Use system protobuf
+ sed -i '/third_party\/protobuf/d' CMakeLists.txt
git submodule init
git config submodule.third_party/onnx.url "$srcdir"/onnx