summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2022-08-06 10:23:01 +0800
committerChih-Hsuan Yen2022-08-06 10:23:01 +0800
commitb623645ac75e7f5bffe74abbf44d9dc3b7188b01 (patch)
tree082d4fc63f98458206a143162bf1904e460ec4d3
parent31bb317da6f283fc4e8e30779263830282091198 (diff)
downloadaur-b623645ac75e7f5bffe74abbf44d9dc3b7188b01.tar.gz
upgrade to 0.3.0
* Upstream switches to an onnx fork * Use CMake options for shared protobuf instead of patching
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fc8ba996a69..49b60c71c15a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-onnxoptimizer
pkgdesc = ONNX model optimizer
- pkgver = 0.2.7
- pkgrel = 3
+ pkgver = 0.3.0
+ pkgrel = 1
url = https://github.com/onnx/optimizer
arch = x86_64
license = MIT
@@ -16,8 +16,8 @@ pkgbase = python-onnxoptimizer
depends = python
depends = python-onnx
options = debug
- source = onnx-optimizer::git+https://github.com/onnx/optimizer.git#tag=v0.2.7
- source = git+https://github.com/onnx/onnx.git
+ source = onnx-optimizer::git+https://github.com/onnx/optimizer.git#tag=v0.3.0
+ source = onnx-daquexian::git+https://github.com/daquexian/onnx.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0ddc305b0fcc..d24f4610e6ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
pkgname=python-onnxoptimizer
-pkgver=0.2.7
+pkgver=0.3.0
pkgdesc='ONNX model optimizer'
-pkgrel=3
+pkgrel=1
arch=(x86_64)
url='https://github.com/onnx/optimizer'
license=(MIT)
@@ -11,7 +11,7 @@ depends=(python python-onnx)
makedepends=(python-setuptools cmake pybind11 git)
checkdepends=(python-pytest python-nbval python-onnxruntime python-torchvision)
source=("onnx-optimizer::git+https://github.com/onnx/optimizer.git#tag=v$pkgver"
- "git+https://github.com/onnx/onnx.git")
+ "onnx-daquexian"::"git+https://github.com/daquexian/onnx.git")
sha256sums=('SKIP'
'SKIP')
options=('debug')
@@ -19,18 +19,16 @@ options=('debug')
prepare() {
cd onnx-optimizer
sed -i '/pytest-runner/d' setup.py
- # Use system protobuf
- sed -i '/third_party\/protobuf/d' CMakeLists.txt
git submodule init
- git config submodule.third_party/onnx.url "$srcdir"/onnx
+ git config submodule.third_party/onnx.url "$srcdir"/onnx-daquexian
git submodule update third_party/onnx
}
build() {
cd onnx-optimizer
- # https://github.com/onnx/optimizer/issues/38
- CMAKE_ARGS="-DONNX_USE_LITE_PROTO=ON" python setup.py build
+ # Use system protobuf and protobuf-lite (https://github.com/onnx/optimizer/issues/38)
+ CMAKE_ARGS="-DONNX_OPT_USE_SYSTEM_PROTOBUF=ON -DONNX_USE_PROTOBUF_SHARED_LIBS=ON -DONNX_USE_LITE_PROTO=ON" python setup.py build
}
check() {