summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2022-08-27 12:33:04 +0800
committerChih-Hsuan Yen2022-08-27 12:33:04 +0800
commit428714cc70c5c37b31c87e31a3f031a012851eac (patch)
treec8865e45293c7be5858e3538b421f6be04cacc02
parent8a32891c87b0cc39067e0b91966f9ced5703afb3 (diff)
downloadaur-428714cc70c5c37b31c87e31a3f031a012851eac.tar.gz
fix building with flatbuffers 2.0.7
Upstream flatbuffers renamed the package from Flatbuffers to FlatBuffers (capital B) [1]. Fixes the issue reported at https://aur.archlinux.org/packages/python-onnxruntime#comment-879320 Also drops patches that are part of the latest version. [1] https://github.com/google/flatbuffers/pull/7378
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--build-fixes.patch10
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a519b1cb0e3..afbc0bca6376 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -56,7 +56,7 @@ pkgbase = python-onnxruntime
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = ab0446ede08e528ca631a73e536ff42009ee8f152972d37050b2f9b44b3d1c06d19bd8a91c31b09c26f5db1482a699b8fe2c221b78199199dfa245728856b196
+ sha512sums = 6ad02636e2cba8f2e82f5ac733856eee3016750e809ee18a41c4edc78bca761f30ac174d7d683f9b14b9f72310dd654811b1ecc9dda514e12bac6b7440c449c2
sha512sums = 7d55b0d4232183a81c20a5049f259872150536eed799d81a15e7f10b5c8b5279b443ba96d7b97c0e4338e95fc18c9d6f088e348fc7002256ee7170d25b27d80d
sha512sums = 6735c7aca2ba2f1f2a5286eb064125bf7f2c68a575d572dd157769d15778ff3e717b3a53d696c767748229f23ee6c3a7c82679df1d86283d7c4dd0ec9103ae08
diff --git a/PKGBUILD b/PKGBUILD
index f11289013e4b..1bacfd42ec9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -46,7 +46,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'ab0446ede08e528ca631a73e536ff42009ee8f152972d37050b2f9b44b3d1c06d19bd8a91c31b09c26f5db1482a699b8fe2c221b78199199dfa245728856b196'
+ '6ad02636e2cba8f2e82f5ac733856eee3016750e809ee18a41c4edc78bca761f30ac174d7d683f9b14b9f72310dd654811b1ecc9dda514e12bac6b7440c449c2'
'7d55b0d4232183a81c20a5049f259872150536eed799d81a15e7f10b5c8b5279b443ba96d7b97c0e4338e95fc18c9d6f088e348fc7002256ee7170d25b27d80d'
'6735c7aca2ba2f1f2a5286eb064125bf7f2c68a575d572dd157769d15778ff3e717b3a53d696c767748229f23ee6c3a7c82679df1d86283d7c4dd0ec9103ae08')
# CUDA seems not working with LTO
@@ -67,11 +67,6 @@ prepare() {
patch -Np1 -i ../install-orttraining-files.diff
patch -Np1 -i ../system-dnnl.diff
- # Protobuf 3.20 incompatibility https://github.com/microsoft/onnxruntime/pull/11639
- git cherry-pick -n 6aa286f1e3ece96a7326ea55fdcd225f1ff8bbf2
- # Fix building DNNL EP with GCC 12 https://github.com/microsoft/onnxruntime/pull/11667
- git cherry-pick -n 59ca05cb1c1de0492d10ac895904b217c86e612d
-
git submodule init
for mod in onnx SafeInt tensorboard dlpack cxxopts pytorch_cpuinfo; do
git config submodule.cmake/external/$mod.url "$srcdir"/$mod
diff --git a/build-fixes.patch b/build-fixes.patch
index 614a39ce3b8f..2e86341c4d4b 100644
--- a/build-fixes.patch
+++ b/build-fixes.patch
@@ -25,9 +25,15 @@ index a027c69e0..eb7608518 100644
message("Use re2 from preinstalled system lib")
else()
add_subdirectory(external/re2 EXCLUDE_FROM_ALL)
-@@ -1421,7 +1421,7 @@
+@@ -1421,11 +1421,11 @@
+ #Dependencies end. In the next we'll enable "treat warning as error"
+
+ if (onnxruntime_PREFER_SYSTEM_LIB)
+- find_package(Flatbuffers)
++ find_package(FlatBuffers)
endif()
- if (Flatbuffers_FOUND)
+-if (Flatbuffers_FOUND)
++if (FlatBuffers_FOUND)
message("Use flatbuffers from preinstalled system lib")
- add_library(flatbuffers ALIAS flatbuffers::flatbuffers)
+ add_library(flatbuffers ALIAS flatbuffers::flatbuffers_shared)