summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-06-29 23:40:17 +0800
committerlilac2021-06-29 23:40:17 +0800
commit783115a6a55c13e895481b4662198d542a66d669 (patch)
tree19400becf5a4cb4fcd23f93e5e770bf469a872a9
parent8ddd1e0bf5f9b951be1fcf2ec0b72465bd0098bc (diff)
downloadaur-783115a6a55c13e895481b4662198d542a66d669.tar.gz
[lilac] updated to 1.8.0-5
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f1bc1506641..d90403f8e0e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-onnxruntime
pkgdesc = Cross-platform, high performance scoring engine for ML models
pkgver = 1.8.0
- pkgrel = 1
+ pkgrel = 5
url = https://github.com/microsoft/onnxruntime
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 78f18b09f809..f5a70effb19f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=python-onnxruntime
pkgname=(python-onnxruntime python-onnxruntime-cuda)
pkgver=1.8.0
pkgdesc='Cross-platform, high performance scoring engine for ML models'
-pkgrel=1
+pkgrel=5
arch=(x86_64)
url='https://github.com/microsoft/onnxruntime'
license=(MIT)
@@ -36,6 +36,9 @@ sha512sums=('SKIP'
'685f0235abed6e1277dd0eb9bda56c464d1987fe7fc90a3550e17ec70cc49fd15f34996a0e159f9622c4ca3e6bf29917fe51b7849342531fa2a6808d782f1e06'
'55ba879c015df11582ff4afaa9ccca19c0e3d3a8be503629718402dbdc826e36bc3ec3ce4dd589705371d7fcf250ba2a9b30c5a3dd0cfccb8e008346f1bd6252')
+# Check PKGBUILDs of python-pytorch and tensorflow for CUDA architectures built by official packages
+_CUDA_ARCHITECTURES="52-real;53-real;60-real;61-real;62-real;70-real;72-real;75-real;80-real;86-real;86-virtual"
+
prepare() {
cd onnxruntime
@@ -76,14 +79,17 @@ _build() {
build() {
_build build
- # Use clang as GCC does not work. GCC 11 uses C++ 17 by default. On the
- # other hand, onnxruntime uses C++ 14. However, nvcc does not correctly
- # pass -std=c++14 to the host compiler, and thus preprocessed files
- # contains C++ 17 language features, and cicc failed to parse it. GCC 10
- # does not work, either, as some dependent packages (ex: re2) are built
- # with libstdc++ 11, and linking onnxruntime with libstdc++ 10 fails.
+ # 1. Use clang as GCC does not work. GCC 11 crashes with internal
+ # compiler errors. GCC 10 does not work as some dependent packages
+ # (ex: re2) are built with libstdc++ from GCC 11, and thus linking
+ # onnxruntime with libstdc++ 10 fails.
+ # 2. Redefine ___is_signed to ___is_signed to workaround a regression
+ # from CUDA 11.3 -> 11.3.1 [1].
+ # [1] https://forums.developer.nvidia.com/t/182176
_build build-cuda \
-DCMAKE_CUDA_HOST_COMPILER=/usr/bin/clang \
+ -DCMAKE_CUDA_FLAGS="-D__is_signed=___is_signed" \
+ -DCMAKE_CUDA_ARCHITECTURES="$_CUDA_ARCHITECTURES" \
-Donnxruntime_USE_CUDA=ON \
-Donnxruntime_CUDA_HOME=/opt/cuda \
-Donnxruntime_CUDNN_HOME=/usr \
@@ -91,7 +97,9 @@ build() {
}
_check() {
- make test
+ # Test models are no longer publicly available [1]
+ # [1] https://github.com/microsoft/onnxruntime/issues/7447
+ GTEST_FILTER='-*ModelTest*' ARGS="--rerun-failed --output-on-failure" make test
# launch_test.py seems a script, and orttraining_* include BERT tests, which require the
# transformers package, and failed even if the latter is installed.
LD_LIBRARY_PATH="$PWD" pytest \