summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2019-10-29 02:43:32 +0800
committerlilac2019-10-29 02:43:32 +0800
commitee207ed7a515d21c934911be4e7a51f3d30a27a0 (patch)
tree8be8adca9a720fe4216537f905f5fad52b9e43c8
parent5d2f99386b7c4c18265c5d5c181f985be85bda37 (diff)
downloadaur-ee207ed7a515d21c934911be4e7a51f3d30a27a0.tar.gz
update by lilac
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
-rw-r--r--build-fixes.patch12
3 files changed, 13 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14d4e7757087..9c9b3f410ec7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-onnxruntime
pkgdesc = Cross-platform, high performance scoring engine for ML models
- pkgver = 0.5.0
- pkgrel = 1
+ pkgver = 0.5.1
+ pkgrel = 2
url = https://github.com/microsoft/onnxruntime
arch = x86_64
license = MIT
@@ -13,11 +13,10 @@ pkgbase = python-onnxruntime
makedepends = gmock
makedepends = pybind11
makedepends = python-setuptools
- makedepends = protobuf>=3.7.1
depends = protobuf
depends = re2
depends = python-numpy
- source = git+https://github.com/microsoft/onnxruntime#tag=v0.5.0
+ source = git+https://github.com/microsoft/onnxruntime#tag=v0.5.1
source = git+https://github.com/HowardHinnant/date.git
source = eigen::git+https://github.com/eigenteam/eigen-git-mirror.git
source = git+https://github.com/google/gemmlowp.git
@@ -32,7 +31,7 @@ pkgbase = python-onnxruntime
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = c598f14c413c35e923e76770214f464922431255b8b0a5e2ff7851b3447f8af7ee2d0f1349aa63d251097902bd6a506626dabc3a8e7f2a63144a1be5478e5470
+ sha512sums = 14371770514544fbb25016fb6b986501911ca5683584c45855325fa7447dbf8f10735c8d57239996c5ee3dc7cce2a3238150c04564529769c9dcb7edb47e799e
pkgname = python-onnxruntime
@@ -42,6 +41,6 @@ pkgname = python-onnxruntime-cuda
depends = python-numpy
depends = cuda
depends = cudnn
- provides = python-onnxruntime=0.5.0
+ provides = python-onnxruntime=0.5.1
conflicts = python-onnxruntime
diff --git a/PKGBUILD b/PKGBUILD
index d6c8dda8217b..33a2035fde49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,14 @@
pkgbase=python-onnxruntime
pkgname=(python-onnxruntime python-onnxruntime-cuda)
-pkgver=0.5.0
+pkgver=0.5.1
pkgdesc='Cross-platform, high performance scoring engine for ML models'
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url='https://github.com/microsoft/onnxruntime'
license=(MIT)
depends=(protobuf re2 python-numpy)
-# protobuf 3.7.0 has an issue, which breaks building of onnxruntime
-# https://github.com/protocolbuffers/protobuf/issues/5869
-makedepends=(git cmake cuda cudnn gtest gmock pybind11 python-setuptools 'protobuf>=3.7.1' )
+makedepends=(git cmake cuda cudnn gtest gmock pybind11 python-setuptools)
# not de-vendored libraries
# eigen: API changes a lot since extra/eigen 3.3.7 to the commit onnxruntime uses
# onnx: onnxruntime requires headers, which are not installed in python-onnx
@@ -30,10 +28,14 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'c598f14c413c35e923e76770214f464922431255b8b0a5e2ff7851b3447f8af7ee2d0f1349aa63d251097902bd6a506626dabc3a8e7f2a63144a1be5478e5470')
+ '14371770514544fbb25016fb6b986501911ca5683584c45855325fa7447dbf8f10735c8d57239996c5ee3dc7cce2a3238150c04564529769c9dcb7edb47e799e')
prepare() {
cd onnxruntime
+
+ # More protobuf debundling; inspired by https://github.com/microsoft/onnxruntime/pull/1928
+ rm -v onnxruntime/core/util/protobuf_parsing_utils.{h,cc}
+ echo "#include <google/protobuf/io/zero_copy_stream_impl.h>" >> onnxruntime/core/util/protobuf_parsing_utils.h
patch -Np1 -i ../build-fixes.patch
git submodule init
diff --git a/build-fixes.patch b/build-fixes.patch
index e061f592bdb4..be8a75d6b2a8 100644
--- a/build-fixes.patch
+++ b/build-fixes.patch
@@ -83,15 +83,3 @@ index ace16b1b..c76ebde4 100644
)
add_dependencies(onnxruntime_pybind11_state ${onnxruntime_pybind11_state_dependencies})
-diff --git a/onnxruntime/core/util/protobuf_parsing_utils.cc b/onnxruntime/core/util/protobuf_parsing_utils.cc
-index 4e46d0ef..8638f353 100644
---- a/onnxruntime/core/util/protobuf_parsing_utils.cc
-+++ b/onnxruntime/core/util/protobuf_parsing_utils.cc
-@@ -49,7 +49,6 @@
- #include <google/protobuf/stubs/common.h>
- #include <google/protobuf/stubs/logging.h>
- #include <google/protobuf/stubs/stl_util.h>
--#include <google/protobuf/stubs/io_win32.h>
- #include "protobuf_parsing_utils.h"
- #include <string.h>
-