summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Serpieri2018-01-08 21:39:44 -0500
committerMichael Serpieri2018-01-08 21:39:44 -0500
commita51adbb37fcc249ed67b1f237665e1052812597c (patch)
tree4e4f034780347a18f7315ca3988eb170eff5e25f
downloadaur-a51adbb37fcc249ed67b1f237665e1052812597c.tar.gz
1.0.0
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD30
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f163ecd6ad9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-openbrokerapi
+ pkgdesc = A python package for the V2 CF Service Broker API and Open Broker API (version 2.13+)
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/eruvanos/openbrokerapi
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-flask
+ source = python-openbrokerapi::git+https://github.com/eruvanos/openbrokerapi#tag=v1.0.0
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 01fd3820ef015cfa1c6143d706106489
+
+pkgname = python-openbrokerapi
+ depends = python
+ depends = python-flask
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..92020982dea5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2017 Eruvanos
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..995d291692a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: mickybart <mickybart at pygoscelis dot org>
+
+pkgname=('python-openbrokerapi')
+pkgver='1.0.0'
+pkgrel=1
+pkgdesc="A python package for the V2 CF Service Broker API and Open Broker API (version 2.13+)"
+url="https://github.com/eruvanos/openbrokerapi"
+depends=('python' 'python-flask')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("${pkgname}::git+https://github.com/eruvanos/openbrokerapi#tag=v${pkgver}"
+ 'LICENSE')
+md5sums=('SKIP'
+ '01fd3820ef015cfa1c6143d706106489')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ # license
+ install -Dm644 "${srcdir}/LICENSE" "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+