summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-10-06 12:37:23 -0400
committeracxz2020-10-06 12:37:23 -0400
commit80bbbd1b25f4c50644a8331febe3472954b3e121 (patch)
tree940a053ebcce3ec8028a56686b056e4e103959b7
downloadaur-80bbbd1b25f4c50644a8331febe3472954b3e121.tar.gz
create python-opencensus package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ece865980ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-opencensus
+ pkgdesc = A stats collection and distributed tracing framework
+ pkgver = 0.7.10
+ pkgrel = 1
+ url = https://github.com/census-instrumentation/opencensus-python
+ arch = any
+ license = Apache-2.0
+ makedepends = python-setuptools
+ depends = python
+ depends = python-opencensus-context
+ depends = python-google-api-core
+ source = python-opencensus-0.7.10.tar.gz::https://github.com/census-instrumentation/opencensus-python/archive/v0.7.10.tar.gz
+ sha256sums = 6b9a95efd0047e04d2d0b04efc0f38e4f2efdfa72746953cea7e586889f53e7a
+
+pkgname = python-opencensus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13e3aac889d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+
+pkgname=python-opencensus
+pkgver=0.7.10
+pkgrel=1
+pkgdesc='A stats collection and distributed tracing framework'
+arch=('any')
+url='https://github.com/census-instrumentation/opencensus-python'
+license=('Apache-2.0')
+depends=('python' 'python-opencensus-context' 'python-google-api-core')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/census-instrumentation/opencensus-python/archive/v$pkgver.tar.gz")
+sha256sums=('6b9a95efd0047e04d2d0b04efc0f38e4f2efdfa72746953cea7e586889f53e7a')
+
+_pkgname=opencensus-python
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir"/ --optimize=1
+}