summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2020-01-15 10:59:08 +0100
committerTobias Bachmann2020-01-15 10:59:08 +0100
commit404d8a963b5b203532d70a0b371e3610d35f9524 (patch)
tree98976563fcb8740690450f96f1efcc9d879fc44e
parent3d6f6e37db23138d138337b832c5c9009ef9820c (diff)
downloadaur-404d8a963b5b203532d70a0b371e3610d35f9524.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7eae14292543..8c61e86f2633 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-opengl-accelerate
pkgdesc = This is the Cython-coded accelerator module for PyOpenGL 3.x
- pkgver = 3.1.3b1
- pkgrel = 2
+ pkgver = 3.1.5
+ pkgrel = 1
arch = any
license = BSD
depends = python
depends = python-opengl
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/P/PyOpenGL-accelerate/PyOpenGL-accelerate-3.1.3b1.tar.gz
- sha256sums = e687eea7e006d65f531933b49b3b3d2feaaf51279147a904247f9d189762a36f
+ source = https://github.com/mcfletch/pyopengl/archive/3e9791ffb4cd4831dae261d6bea3049ce9e78f01.tar.gz
+ sha256sums = d8547b182938aff99eb202edb94f712127d535611f976bd2aaf72650fcef3531
pkgname = python-opengl-accelerate
diff --git a/PKGBUILD b/PKGBUILD
index d9251f07e1a5..8951940053fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=python-opengl-accelerate
-pkgver=3.1.3b1 # We have to use the beta version for now, as 3.1.0 does not support Python 3.7
-pkgrel=2
+pkgver=3.1.5
+pkgrel=1
+_commit=3e9791ffb4cd4831dae261d6bea3049ce9e78f01 # McFletch does not release bundles on GitHub, there we use commit hashes to get specific versions
pkgdesc="This is the Cython-coded accelerator module for PyOpenGL 3.x"
-_name=PyOpenGL-accelerate
+_name=pyopengl
arch=('any')
url=""
license=('BSD')
@@ -16,12 +17,17 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('e687eea7e006d65f531933b49b3b3d2feaaf51279147a904247f9d189762a36f')
+source=("https://github.com/mcfletch/${_name}/archive/${_commit}.tar.gz")
+sha256sums=('d8547b182938aff99eb202edb94f712127d535611f976bd2aaf72650fcef3531')
+
+build() {
+ cd "$srcdir/${_name}-${_commit}/accelerate"
+ python setup.py build
+}
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/${_name}-${_commit}/accelerate"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
# vim:set ts=2 sw=2 et: