summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2017-10-11 13:10:27 +0200
committerTobias Bachmann2017-10-11 13:10:27 +0200
commit52687332338527fea8d7afcd7b88488075ccca2a (patch)
treed349de3e9de6a580d47960fd7c87494477902bf6
downloadaur-52687332338527fea8d7afcd7b88488075ccca2a.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4fd15796a57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-opengl-accelerate
+ pkgver = 3.1.0
+ pkgrel = 1
+ arch = any
+ license = BSD
+ depends = python
+ depends = python-opengl
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/P/PyOpenGL-accelerate/PyOpenGL-accelerate-3.1.0.tar.gz
+ sha256sums = 927f4670b893d46e2f6273ae938bf0a1db27ffae3336eba94813ccef6260c410
+
+pkgname = python-opengl-accelerate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb7846b209fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
+pkgname=python-opengl-accelerate
+pkgver=3.1.0
+pkgrel=1
+pkgdesc=""
+_name=PyOpenGL-accelerate
+arch=('any')
+url=""
+license=('BSD')
+groups=()
+depends=('python' 'python-opengl')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('927f4670b893d46e2f6273ae938bf0a1db27ffae3336eba94813ccef6260c410')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: