summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2023-07-30 18:46:30 +0200
committerTobias Bachmann2023-07-30 18:46:30 +0200
commita56f0fd0a85d24a30d7fb8b22c1ba60ad1212590 (patch)
tree3d4ae173acd7e7ae4af07f44689340311f97fb24
parent17e1f74305500edce9b54c7c97fe3c3a9cd67727 (diff)
downloadaur-a56f0fd0a85d24a30d7fb8b22c1ba60ad1212590.tar.gz
Version bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe02b7170560..1e8e63ef5961 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = python-opengl-accelerate
pkgdesc = This is the Cython-coded accelerator module for PyOpenGL 3.x
- pkgver = 3.1.6
+ pkgver = 3.1.7
pkgrel = 1
arch = any
license = BSD
depends = python
depends = python-opengl
options = !emptydirs
- source = https://github.com/mcfletch/pyopengl/archive/227f9c66976d9f5dadf62b9a97e6beaec84831ca.tar.gz
- sha256sums = 6b556e5aa2fd6517809e1559593038c99d3318d21155be4de3d18acfef093d40
+ source = python-opengl-accelerate-3.1.7.tar.gz::https://files.pythonhosted.org/packages/source/P/PyOpenGL-accelerate/PyOpenGL-accelerate-3.1.7.tar.gz
+ sha256sums = 2b123621273a939f7fd2ec227541e399f9b5d4e815d69ae0bdb1b6c70a293680
pkgname = python-opengl-accelerate
diff --git a/PKGBUILD b/PKGBUILD
index ce428961eb44..389b507e982a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=python-opengl-accelerate
-pkgver=3.1.6
+pkgver=3.1.7
pkgrel=1
-_commit=227f9c66976d9f5dadf62b9a97e6beaec84831ca # McFletch does not release bundles on GitHub, therefore we use commit hashes to get specific versions
pkgdesc="This is the Cython-coded accelerator module for PyOpenGL 3.x"
-_name=pyopengl
+_name=PyOpenGL-accelerate
arch=('any')
url=""
license=('BSD')
@@ -17,16 +16,17 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("https://github.com/mcfletch/${_name}/archive/${_commit}.tar.gz")
-sha256sums=('6b556e5aa2fd6517809e1559593038c99d3318d21155be4de3d18acfef093d40')
+#source=("https://github.com/mcfletch/${_name}/archive/${_commit}.tar.gz")
+source=($pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
+sha256sums=('2b123621273a939f7fd2ec227541e399f9b5d4e815d69ae0bdb1b6c70a293680')
build() {
- cd "$srcdir/${_name}-${_commit}/accelerate"
+ cd "$srcdir/${_name}-${pkgver}"
python setup.py build
}
package() {
- cd "$srcdir/${_name}-${_commit}/accelerate"
+ cd "$srcdir/${_name}-${pkgver}"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}