summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:54:40 +0200
committerLubosz Sarnecki2015-06-22 22:54:40 +0200
commit18e156a94ab8da723ba882a7ebe8bcc34f0c9201 (patch)
treec413358684ad0653162513f77a31cbfc0e7cad8b
downloadaur-18e156a94ab8da723ba882a7ebe8bcc34f0c9201.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d642aaf02c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-openglcontext
+ pkgdesc = OpenGLcontext is a learning environment for PyOpenGL.
+ pkgver = 2.2.0a3
+ pkgrel = 1
+ url = http://pyopengl.sourceforge.net/context
+ arch = any
+ license = BSD
+ depends = python2-opengl
+ provides = python2-openglcontext
+ source = https://pypi.python.org/packages/source/O/OpenGLContext/OpenGLContext-2.2.0a3.tar.gz
+ md5sums = b5bdedbdae5215e7acff3b087c8220d3
+
+pkgname = python-openglcontext
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a452b5a14538
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+# Contributor: Douglas Soares de Andrade <dsandrade@gmail.com>
+# Contributor: Mathieu Pasquet <mathieui> <mathieuivi@gmail.com>
+
+pkgname=python-openglcontext
+pkgver=2.2.0a3
+pkgrel=1
+arch='any'
+pkgdesc="OpenGLcontext is a learning environment for PyOpenGL."
+depends=('python2-opengl')
+url="http://pyopengl.sourceforge.net/context"
+source=("https://pypi.python.org/packages/source/O/OpenGLContext/OpenGLContext-2.2.0a3.tar.gz")
+license='BSD' #BSD-style, though, see license.txt in the archive file
+
+provides=('python2-openglcontext')
+
+md5sums=('b5bdedbdae5215e7acff3b087c8220d3')
+
+pkgver() {
+ cd openglcontext
+ echo $(grep __version__ OpenGLContext/__init__.py | sed 's/__version__ = "//' | sed 's/"//')
+}
+
+build() {
+ cd openglcontext
+ python2 setup.py build
+}
+
+package() {
+ cd openglcontext
+ python2 setup.py install --root=$pkgdir
+}