summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2022-02-04 15:26:10 -0500
committerBuildTools2022-02-04 15:26:10 -0500
commita7549d69592bf12bb74d35e5ca14f4801869c2f8 (patch)
tree6c2f16da06f3d42b437d08441e7b087c03bed38e
parent08999e913dfd49438972956dbbbbac976f561317 (diff)
downloadaur-a7549d69592bf12bb74d35e5ca14f4801869c2f8.tar.gz
dropping python2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 7 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed8a628460a4..1707e5a7c8a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,12 @@
pkgbase = python-openid-cla
pkgdesc = CLA extension for python-openid
pkgver = 1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/puiterwijk/python-openid-cla/
arch = any
license = BSD
+ depends = python-openid
source = https://github.com/puiterwijk/python-openid-cla/archive/v1.2.tar.gz
sha256sums = 1ca811f26cc4609b3d2a283c526732e6a75cc9f4f0e43039518e244d7f8939a2
pkgname = python-openid-cla
- pkgdesc = Utilities used around Fedora Infrastructure to send and receive messages (Python 3 version)
- depends = python-openid
-
-pkgname = python2-openid-cla
- pkgdesc = Utilities used around Fedora Infrastructure to send and receive messages (Python 2 version)
- depends = python2-openid
-
diff --git a/PKGBUILD b/PKGBUILD
index be6a1aa46986..337e1638fe20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,21 @@
# Maintainer: Jameson Pugh <imntreal@gmail.com>
-pkgbase=python-openid-cla
-pkgname=('python-openid-cla' 'python2-openid-cla')
+pkgname=python-openid-cla
pkgver=1.2
-pkgrel=1
+pkgrel=2
pkgdesc='CLA extension for python-openid'
arch=(any)
url='https://github.com/puiterwijk/python-openid-cla/'
license=(BSD)
-makedeps=('python-setuptools' 'python2-setuptools')
+depends=('python-openid')
+makedeps=('python-setuptools')
source=("https://github.com/puiterwijk/python-openid-cla/archive/v${pkgver}.tar.gz")
sha256sums=('1ca811f26cc4609b3d2a283c526732e6a75cc9f4f0e43039518e244d7f8939a2')
-package_python-openid-cla() {
- pkgdesc='Utilities used around Fedora Infrastructure to send and receive messages (Python 3 version)'
- depends=('python-openid')
+package() {
cd "python-openid-cla-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
}
-package_python2-openid-cla() {
- pkgdesc='Utilities used around Fedora Infrastructure to send and receive messages (Python 2 version)'
- depends=('python2-openid')
- cd "python-openid-cla-${pkgver}"
-
- python2 setup.py install --root="$pkgdir" --optimize=1
-}
-
# vim:set ts=2 sw=2 et: