summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriele Musco2020-06-20 10:44:22 +0200
committerGabriele Musco2020-06-20 10:44:22 +0200
commit93596c7dd72500d3143c0a7cdbeea14ea270aad8 (patch)
tree4cee0ed623a0b0c7a94420e9d23dd567362e6da1
downloadaur-93596c7dd72500d3143c0a7cdbeea14ea270aad8.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3f071e9b843
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-openrgb-git
+ pkgdesc = A python client for the OpenRGB SDK
+ pkgver = v0.0.5.r1.gf32661a
+ pkgrel = 1
+ url = https://github.com/jath03/openrgb-python
+ arch = any
+ license = GPL-3.0
+ makedepends = python-setuptools
+ makedepends = git
+ depends = openrgb
+ depends = python
+ provides = python-openrgb
+ conflicts = python-openrgb
+ source = python-openrgb::git+https://github.com/jath03/openrgb-python
+ sha256sums = SKIP
+
+pkgname = python-openrgb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa0d3baa9031
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gabriele Musco <emaildigabry@gmail.com>
+# Upstream URL: https://github.com/jath03/openrgb-python
+
+pkgname=python-openrgb-git
+pkgver=v0.0.5.r1.gf32661a
+pkgrel=1
+pkgdesc="A python client for the OpenRGB SDK"
+arch=('any')
+url="https://github.com/jath03/openrgb-python"
+license=('GPL-3.0')
+makedepends=('python-setuptools' 'git')
+depends=('openrgb' 'python')
+conflicts=('python-openrgb')
+provides=('python-openrgb')
+source=("python-openrgb::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/python-openrgb"
+ git describe --long --tags --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/python-openrgb"
+ python setup.py install --root="${pkgdir}"
+}