summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-05-14 01:55:17 +0300
committerCaleb Maclennan2020-05-14 10:49:41 +0300
commit1f57d917ab4481dfa0c3f6daa5f70d158a0fdad8 (patch)
tree52cd1a52579feb77fcdfd797a637178664546ad5
parentdffe90e2f5788a37e106d4f19bee7e5034754328 (diff)
downloadaur-1f57d917ab4481dfa0c3f6daa5f70d158a0fdad8.tar.gz
Modify to use the system ots-sanitize binary
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
-rw-r--r--system-ots-sanitize.patch21
3 files changed, 37 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ad4b4c03c50..34f654b2d424 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = python-opentype-sanitizer
pkgdesc = Python wheels for the OpenType Sanitizer
pkgver = 8.0.0.post2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/googlefonts/otf-python
arch = any
license = GPL3
- makedepends = meson
- makedepends = ninja
makedepends = python-setuptools
- depends = freetype2
depends = python
- depends = zlib
+ depends = ots
source = https://files.pythonhosted.org/packages/source/o/opentype-sanitizer/opentype-sanitizer-8.0.0.post2.tar.gz
+ source = system-ots-sanitize.patch
sha256sums = 95bbd6ce193841654aef95237e95197addbc0495daa9da2947f64f5ccd86ef38
+ sha256sums = 6388d57e44f3dc7d6ee91422b30ca9eca3e3c590bacaa7bc4664b6183ed4d065
pkgname = python-opentype-sanitizer
diff --git a/PKGBUILD b/PKGBUILD
index e0e1bf470730..919121cb89c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,22 @@ _project=otf-python
_pyname=opentype-sanitizer
pkgname=python-$_pyname
pkgver=8.0.0.post2
-pkgrel=2
+pkgrel=3
pkgdesc='Python wheels for the OpenType Sanitizer'
arch=('any')
url="https://github.com/googlefonts/$_project"
license=('GPL3')
-depends=('freetype2'
- 'python'
- 'zlib')
-makedepends=('meson' 'ninja' 'python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz")
-sha256sums=('95bbd6ce193841654aef95237e95197addbc0495daa9da2947f64f5ccd86ef38')
+depends=('python' 'ots')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz"
+ system-ots-sanitize.patch)
+sha256sums=('95bbd6ce193841654aef95237e95197addbc0495daa9da2947f64f5ccd86ef38'
+ '6388d57e44f3dc7d6ee91422b30ca9eca3e3c590bacaa7bc4664b6183ed4d065')
+
+prepare () {
+ cd "$_pyname-$pkgver"
+ patch -p0 < "$srcdir/system-ots-sanitize.patch"
+}
build() {
cd "$_pyname-$pkgver"
diff --git a/system-ots-sanitize.patch b/system-ots-sanitize.patch
new file mode 100644
index 000000000000..8ca4a51360af
--- /dev/null
+++ b/system-ots-sanitize.patch
@@ -0,0 +1,21 @@
+--- setup.py.orig 2020-05-14 01:06:32.246745855 +0300
++++ setup.py 2020-05-14 01:06:37.623442253 +0300
+@@ -236,7 +236,6 @@
+ platforms=["posix", "nt"],
+ package_dir={"": "src/python"},
+ packages=find_packages("src/python"),
+- ext_modules=[ots_sanitize],
+ zip_safe=False,
+ cmdclass=cmdclass,
+ setup_requires=["setuptools_scm"],
+--- src/python/ots/__init__.py.orig 2020-05-14 01:06:02.026581362 +0300
++++ src/python/ots/__init__.py 2020-05-14 01:06:17.789999936 +0300
+@@ -3,7 +3,7 @@
+ import sys
+ import os
+
+-OTS_SANITIZE = os.path.join(os.path.dirname(__file__), "ots-sanitize")
++OTS_SANITIZE = "/usr/bin/ots-sanitize"
+
+ __all__ = ["sanitize", "OTSError", "CalledProcessError"]
+