summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-08-17 15:13:15 +0300
committerCaleb Maclennan2021-08-17 15:13:15 +0300
commit7b3529e2c691365581eaa3fe291425677af8d221 (patch)
tree3c1eefa2cbc9d1a74b387388f39cba3bf01e4f69
parentc5aa3a6926320839a13f816f02c99b1ec2adf4e2 (diff)
downloadaur-7b3529e2c691365581eaa3fe291425677af8d221.tar.gz
upgpkg: python-opentype-sanitizer 8.1.4.post3-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cd0e3bad355..b9fc6e16874d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = python-opentype-sanitizer
pkgdesc = Python wheels for the OpenType Sanitizer
- pkgver = 8.1.4.post2
- pkgrel = 2
+ pkgver = 8.1.4.post3
+ pkgrel = 1
url = https://github.com/googlefonts/ots-python
arch = any
license = GPL3
checkdepends = python-pytest
checkdepends = woff2
makedepends = python-setuptools-scm
- depends = python
depends = ots
- source = https://files.pythonhosted.org/packages/source/o/opentype-sanitizer/opentype-sanitizer-8.1.4.post2.tar.gz
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/o/opentype-sanitizer/opentype-sanitizer-8.1.4.post3.tar.gz
source = system-ots-sanitize.patch
- sha256sums = b785b20f4481656666b9d2637533388206c92034bc885660f3ace8635a9293fe
+ sha256sums = 112efdd99915781e4fb79e165832dacf61c0335db4738fd9043b960a8c9f8d91
sha256sums = 6388d57e44f3dc7d6ee91422b30ca9eca3e3c590bacaa7bc4664b6183ed4d065
pkgname = python-opentype-sanitizer
diff --git a/PKGBUILD b/PKGBUILD
index 32c8c004e998..79bb43ce762e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,40 @@
_project=ots-python
_pyname=opentype-sanitizer
pkgname=python-$_pyname
-pkgver=8.1.4.post2
-pkgrel=2
+pkgver=8.1.4.post3
+pkgrel=1
pkgdesc='Python wheels for the OpenType Sanitizer'
arch=(any)
url="https://github.com/googlefonts/$_project"
license=(GPL3)
-depends=(python ots)
-checkdepends=(python-pytest woff2)
+depends=(ots
+ python)
+checkdepends=(python-pytest
+ woff2)
makedepends=(python-setuptools-scm)
-source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz"
+_archive="$_pyname-$pkgver"
+source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz"
system-ots-sanitize.patch)
-sha256sums=('b785b20f4481656666b9d2637533388206c92034bc885660f3ace8635a9293fe'
+sha256sums=('112efdd99915781e4fb79e165832dacf61c0335db4738fd9043b960a8c9f8d91'
'6388d57e44f3dc7d6ee91422b30ca9eca3e3c590bacaa7bc4664b6183ed4d065')
prepare () {
- cd "$_pyname-$pkgver"
+ cd "$_archive"
patch -p0 < "../system-ots-sanitize.patch"
}
build() {
- cd "$_pyname-$pkgver"
+ cd "$_archive"
+ export PYTHONHASHSEED=0
python setup.py build
}
check() {
- cd "$_pyname-$pkgver"
+ cd "$_archive"
PYTHONPATH=src/python pytest
}
package() {
- cd "$_pyname-$pkgver"
+ cd "$_archive"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}