summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBert Peters2021-08-08 10:48:35 +0200
committerBert Peters2021-08-08 10:48:35 +0200
commit93d4f0285bfd6041779128aadb7eb29913743a28 (patch)
treea6abb97a690190fba94aaed2b8a583a31393add9
downloadaur-93d4f0285bfd6041779128aadb7eb29913743a28.tar.gz
Initial upload: python-opnieuw 1.1.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e209a472fc68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-opnieuw
+ pkgdesc = A general-purpose retrying library, written in pure Python
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/channable/opnieuw
+ arch = any
+ license = BSD
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python
+ source = python-opnieuw-1.1.0.tar.gz::https://github.com/channable/opnieuw/archive/refs/tags/v1.1.0.tar.gz
+ sha256sums = 3a59a718f5032d9165d528fe95ea41c539d91eecba8af2c2025e5936f3748e9d
+
+pkgname = python-opnieuw
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bce4de23b3d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Bert Peters <bert@bertptrs.nl>
+pkgname=python-opnieuw
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A general-purpose retrying library, written in pure Python"
+arch=('any')
+url="https://github.com/channable/opnieuw"
+license=('BSD')
+depends=('python')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('3a59a718f5032d9165d528fe95ea41c539d91eecba8af2c2025e5936f3748e9d')
+
+build() {
+ cd "opnieuw-$pkgver"
+ python setup.py build
+}
+
+check() {
+ cd "opnieuw-$pkgver"
+ pytest tests
+}
+
+package() {
+ cd "opnieuw-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+}