summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-01-08 23:43:32 -0500
committerCarlos Aznarán2024-01-08 23:43:32 -0500
commite9c7e1f3c923d052fdd14a86a27631bd9416bfba (patch)
treec02bbb2a009009c93684c0efe9615c56cd12964f
downloadaur-e9c7e1f3c923d052fdd14a86a27631bd9416bfba.tar.gz
Bump version to 0.0.6
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD32
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..622ac4165c5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-optimistix
+ pkgdesc = Nonlinear optimisation in JAX and Equinox
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = https://github.com/patrick-kidger/optimistix
+ arch = any
+ license = Apache
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-hatchling
+ makedepends = python-wheel
+ depends = python-lineax
+ source = optimistix-0.0.6.tar.gz::https://github.com/patrick-kidger/optimistix/archive/v0.0.6.tar.gz
+ sha512sums = 4d756b3160df9925f8f32071e9fb94e2637c2f82769f69aa296f63b1a8e81234239be7c17ced2148bbb8fa441a976aea951fe0a65619b45e481d5c7ef6e19adb
+
+pkgname = python-optimistix
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6788adc60f2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=optimistix
+pkgname=python-${_base}
+pkgdesc="Nonlinear optimisation in JAX and Equinox"
+pkgver=0.0.6
+pkgrel=1
+arch=(any)
+url="https://github.com/patrick-kidger/${_base}"
+license=(Apache)
+depends=(python-lineax)
+makedepends=(python-build python-installer python-hatchling python-wheel)
+# checkdepends=(python-pytest python-beartype python-optax)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('4d756b3160df9925f8f32071e9fb94e2637c2f82769f69aa296f63b1a8e81234239be7c17ced2148bbb8fa441a976aea951fe0a65619b45e481d5c7ef6e19adb')
+
+build() {
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+# check() {
+# cd ${_base}-${pkgver}
+# python -m venv --system-site-packages test-env
+# test-env/bin/python -m installer dist/*.whl
+# test-env/bin/python -m pytest tests
+# }
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}