summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSameer Puri2019-09-18 16:13:19 -0500
committerSameer Puri2019-09-18 16:13:19 -0500
commit93651645261e743f4b0629258c55c4ae06d2eeed (patch)
tree1a84a543856a010595a0746ea626fec4bb02132e
parentd268befeacb71aa26383a8c3d76389b2a5de80f4 (diff)
downloadaur-93651645261e743f4b0629258c55c4ae06d2eeed.tar.gz
Swap to using pypi wheel to build package, update to 7.3
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0804029a476..c0225de9dd0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,27 @@
# Maintainer: Dario Ostuni <another.code.996@gmail.com>
pkgname=python-or-tools
-pkgver=6.8
+pkgver=7.3
pkgrel=1
pkgdesc="Google's Operations Research tools"
arch=('x86_64' 'i686' 'aarch64' 'armv7h')
url="https://github.com/google/or-tools"
license=('Apache2')
-depends=('python>=3.7' 'python<3.8' 'swig')
+depends=('python>=3.5' 'python<3.8' 'swig' 'python-protobuf')
makedepends=('cmake' 'wget' 'lsb-release')
options=(!emptydirs)
source=("https://github.com/google/or-tools/archive/v${pkgver}.tar.gz")
-sha384sums=('2bff8942c56ff819e1907c7d08914c45c139c7a237f381f42f621479dfed22cd9a1617d74f2798f1268da4b0e79692a3')
+sha384sums=('a95161da7144d60d31bc222a288acb666460233a23535dc9f3196d78df0934233664d79fda0555ccd7a9bb83b19bf80f')
build() {
cd "${srcdir}/or-tools-${pkgver}"
- mkdir -p "dependencies/install/lib"
- pushd "dependencies/install"
- ln -s "lib" "lib64"
- popd
- make third_party -j1
+ make third_party
make python
+ make pypi_archive
}
package() {
cd "${srcdir}/or-tools-${pkgver}"
- mkdir -p "$pkgdir/usr/lib/python3.7/site-packages/"
- find ortools/ -name '*.py' -or -name '*.so' | xargs cp --parents -t "$pkgdir/usr/lib/python3.7/site-packages/"
- cp "lib/libortools.so" "$pkgdir/usr/lib/"
+ /usr/bin/pip --quiet install --root="$pkgdir" \
+ --no-deps --ignore-installed --no-warn-script-location \
+ "$(find -name 'ortools*whl')"
}