summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-07-31 18:23:10 +0200
committerMichel Zou2019-07-31 18:23:10 +0200
commit748d5fdaf90d72a5b881431a218fd59b6725966b (patch)
tree7ac9dcd019af377fd23d6e2668808753dc426a2f
parent6a4e89ded00fe857517038f8d0f4cd6ffe6d8d41 (diff)
downloadaur-748d5fdaf90d72a5b881431a218fd59b6725966b.tar.gz
3.22.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD6
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06f01356188e..c10281f7734a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,33 @@
pkgbase = python-orange
pkgdesc = Open source data visualization and analysis for novice and experts. Data mining through visual programming or Python scripting.
- pkgver = 3.20.1
+ pkgver = 3.22.0
pkgrel = 1
url = http://orange.biolab.si/
arch = i686
arch = x86_64
license = GPL3
makedepends = python-setuptools
- depends = python-beautifulsoup4
depends = python-chardet
depends = python-docutils
depends = python-pyqtgraph
depends = python-xlrd
depends = python-matplotlib
depends = python-scikit-learn
- depends = python-recommonmark
- depends = python-sqlparse
depends = python-psycopg2
depends = python-joblib
depends = python-keyrings-alt
depends = python-bottleneck
depends = python-anyqt
- depends = python-dill
depends = python-pip
depends = python-serverfiles
depends = python-louvain
depends = python-xlsxwriter
depends = python-opentsne
- source = https://github.com/biolab/orange3/archive/3.20.1.tar.gz
- sha256sums = 184fd410153d5ed4fceb4673be51ae6706d12697145fe1dd801c0a3c78f8522f
+ depends = python-networkx
+ depends = python-requests
+ depends = python-pandas
+ source = https://github.com/biolab/orange3/archive/3.22.0.tar.gz
+ sha256sums = 652d13727c278db849cca506f64773d26efde0a4567f90d6241a53e1db886190
pkgname = python-orange
diff --git a/PKGBUILD b/PKGBUILD
index 545101928d51..4ac8c7cdca0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
pkgname=python-orange
-pkgver=3.20.1
+pkgver=3.22.0
pkgrel=1
pkgdesc="Open source data visualization and analysis for novice and experts. Data mining through visual programming or Python scripting."
arch=('i686' 'x86_64')
url="http://orange.biolab.si/"
license=('GPL3')
makedepends=('python-setuptools')
-depends=('python-beautifulsoup4' 'python-chardet' 'python-docutils' 'python-pyqtgraph' 'python-xlrd' 'python-matplotlib' 'python-scikit-learn' 'python-recommonmark' 'python-sqlparse' 'python-psycopg2' 'python-joblib' 'python-keyrings-alt' 'python-bottleneck' 'python-anyqt' 'python-dill' 'python-pip' 'python-serverfiles' 'python-louvain' 'python-xlsxwriter' 'python-opentsne')
+depends=('python-chardet' 'python-docutils' 'python-pyqtgraph' 'python-xlrd' 'python-matplotlib' 'python-scikit-learn' 'python-psycopg2' 'python-joblib' 'python-keyrings-alt' 'python-bottleneck' 'python-anyqt' 'python-pip' 'python-serverfiles' 'python-louvain' 'python-xlsxwriter' 'python-opentsne' 'python-networkx' 'python-requests' 'python-pandas')
source=("https://github.com/biolab/orange3/archive/${pkgver}.tar.gz")
-sha256sums=('184fd410153d5ed4fceb4673be51ae6706d12697145fe1dd801c0a3c78f8522f')
+sha256sums=('652d13727c278db849cca506f64773d26efde0a4567f90d6241a53e1db886190')
build() {
cd "${srcdir}/orange3-$pkgver"