summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-06-08 23:54:25 +0200
committerxantares2015-06-08 23:54:25 +0200
commitbd129d92cda970965886d45ce6a5133fa3dac045 (patch)
tree2e102c2ee21e8451bdadf4f3593afd7ed1cd0dfb
downloadaur-bd129d92cda970965886d45ce6a5133fa3dac045.tar.gz
initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD22
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9d181584c05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python-orange
+ pkgdesc = Open source data visualization and analysis for novice and experts. Data mining through visual programming or Python scripting.
+ pkgver = 3.1
+ pkgrel = 1
+ url = http://orange.biolab.si/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ optdepends = python-pyqt4: GUI support
+ source = https://github.com/biolab/orange3/archive/3.1.tar.gz
+ source = http://orange.biolab.si/download/files/archive/Orange-2.7.2.tar.gz
+ md5sums = bb6011d0db23f3ba2720431342614a65
+ md5sums = SKIP
+
+pkgname = python-orange
+ depends = python-matplotlib
+ depends = python-scikit-learn
+ depends = python-pyqt4
+
+pkgname = python2-orange
+ depends = python2-matplotlib
+ depends = python2-scikit-learn
+ depends = python2-pyqt4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f6a4f1d68cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=python-orange
+pkgver=3.1
+pkgrel=1
+pkgdesc="Open source data visualization and analysis for novice and experts. Data mining through visual programming or Python scripting."
+arch=('i686' 'x86_64')
+url="http://orange.biolab.si/"
+license=('GPL3')
+makedepends=('python-setuptools')
+depends=('python-matplotlib' 'python-scikit-learn' 'python-pyqt4')
+optdepends=('python-pyqt4: GUI support')
+source=("https://github.com/biolab/orange3/archive/${pkgver}.tar.gz")
+md5sums=('bb6011d0db23f3ba2720431342614a65')
+
+build() {
+ cd "${srcdir}/orange3-$pkgver"
+ python setup.py build
+}
+
+packag() {
+ cd "${srcdir}/orange3-$pkgver"
+ python setup.py install --root="${pkgdir}"
+}