summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Dems2023-06-05 17:54:12 +0200
committerMaciej Dems2023-06-05 17:54:12 +0200
commit22b26c9ac290254b4520cd3a97eee3968b7c657d (patch)
tree194929aa742b6380e924eace800deeab7e7b3764
downloadaur-22b26c9ac290254b4520cd3a97eee3968b7c657d.tar.gz
v1.0.3
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..188eed6881e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-orcid
+ pkgdesc = A python wrapper over the ORCID API
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/ORCID/python-orcid
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-simplejson
+ source = https://files.pythonhosted.org/packages/source/o/orcid/orcid-1.0.3.tar.gz
+ sha256sums = 5fe28b6d92aed5abe7145c959e4fa2afb90260be215ff3f36ad31c94ee41d0db
+
+pkgname = python-orcid
+ depends = python
+ depends = python-simplejson
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9da8b3cb96e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg
+src
+*.pkg.tar.*
+orcid-*.tar.gz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60ea13ade285
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase='python-orcid'
+pkgname=('python-orcid')
+_module='orcid'
+pkgver='1.0.3'
+pkgrel=1
+pkgdesc="A python wrapper over the ORCID API"
+url="https://github.com/ORCID/python-orcid"
+depends=('python' 'python-simplejson')
+makedepends=('python-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('5fe28b6d92aed5abe7145c959e4fa2afb90260be215ff3f36ad31c94ee41d0db')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}