summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-01-06 12:01:55 -0500
committerclintval2018-01-06 12:01:55 -0500
commitb36bb7581701ca5d2ac224ebe69b59580aa106d9 (patch)
treeb3f45230c7c012b27d794f6d39e93d670823c039
downloadaur-b36bb7581701ca5d2ac224ebe69b59580aa106d9.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c19ef2029618
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-ordered-set
+ pkgdesc = Python MutableSet that remembers its order, so that every entry has an index
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/ordered-set
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = python-ordered-set
+ conflicts = python-ordered-set
+ options = !emptydirs
+ source = https://pypi.python.org/packages/c3/1c/4ddba479a75369b31655e295463bc37e5f84acb4fa7f34548946ff0160e3/ordered-set-2.0.2.tar.gz
+ md5sums = 7b8d73dc64fd3c783ecb48e050bfcc0d
+
+pkgname = python-ordered-set
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40af5bae2a6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-ordered-set'
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="Python MutableSet that remembers its order, so that every entry has an index"
+arch=('any')
+url="https://pypi.python.org/pypi/ordered-set"
+license=('MIT')
+depends=(
+ 'python'
+)
+makedepends=('python-setuptools')
+optdepends=()
+provides=('python-ordered-set')
+conflicts=('python-ordered-set')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/c3/1c/4ddba479a75369b31655e295463bc37e5f84acb4fa7f34548946ff0160e3/ordered-set-2.0.2.tar.gz")
+md5sums=('7b8d73dc64fd3c783ecb48e050bfcc0d')
+
+package() {
+ cd "${srcdir}/ordered-set-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}