summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRené Küttner2015-11-29 12:19:07 +0100
committerRené Küttner2015-11-29 12:19:07 +0100
commita277a803080491cb9621029a142763a6a7755aef (patch)
tree9ae7450e9e2476700f6da17bd72f0775551accab
downloadaur-a277a803080491cb9621029a142763a6a7755aef.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cf03a4f2c50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-orderedset
+ pkgdesc = An ordered set implementation in cython
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/orderedset/
+ arch = any
+ license = BSD
+ makedepends = cython
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.python.org/packages/source/o/orderedset/orderedset-1.2.tar.gz
+ sha512sums = 1ad2abdd4a0fa7ae9c915ae7beb6f96a30280cf6a9bf39eed32a9109af53a464791111c96037ea37f2cef839b48410acc1098b475e8afa5de8b405ce3da06b61
+
+pkgname = python-orderedset
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b9edfd1c82c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: renek <aur@spaceshore.net>
+_pkgname=orderedset
+pkgname=python-${_pkgname}
+pkgver=1.2
+pkgrel=1
+pkgdesc="An ordered set implementation in cython"
+arch=('any')
+url='https://pypi.python.org/pypi/orderedset/'
+license=('BSD')
+depends=('python')
+makedepends=('cython' 'python-setuptools')
+source=("https://pypi.python.org/packages/source/o/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha512sums=('1ad2abdd4a0fa7ae9c915ae7beb6f96a30280cf6a9bf39eed32a9109af53a464791111c96037ea37f2cef839b48410acc1098b475e8afa5de8b405ce3da06b61')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}