summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Rehfeld2021-03-27 22:51:18 +0100
committerHauke Rehfeld2021-03-27 22:51:18 +0100
commit27af60d6bc85a766924501333b11c54035ea953e (patch)
tree5681077420651678b6796513b31ec37b9ace0663
downloadaur-27af60d6bc85a766924501333b11c54035ea953e.tar.gz
add: initial
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83ce216eb204
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-orgparse
+ pkgdesc = orgparse - Emacs org-mode parser in Python
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/karlicoss/orgparse
+ arch = any
+ license = BSD
+ license = License
+ makedepends = python
+ makedepends = python-pip
+
+pkgname = python-orgparse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99b0c2e9baa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# PKGBUILD generated by pipman
+# Python package author: Takafumi Arakaki, Dmitrii Gerasimov <aka.tkf@gmail.com>
+pkgname=python-orgparse
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="orgparse - Emacs org-mode parser in Python"
+arch=(any)
+url="https://github.com/karlicoss/orgparse"
+license=(BSD License)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="orgparse" orgparse==0.2.3
+}
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p $pkgdir/"$sitepackages"
+ cp -r $srcdir/orgparse/* $pkgdir/"$sitepackages"
+} \ No newline at end of file