summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquim Monteiro2020-03-08 02:21:03 +0000
committerJoaquim Monteiro2020-03-08 02:21:03 +0000
commit1145b5c33e011c446f39a7918d8ee9e3b68dc7d4 (patch)
treed9ca7175231523ae28772e9124c0927e705d31ec
parentc7181444e8797dca826f7e1b90e1e47cf59e31bd (diff)
downloadaur-1145b5c33e011c446f39a7918d8ee9e3b68dc7d4.tar.gz
Build and install wheel in a single step
This avoids having to "guess" the built wheel's name, at the cost of unifying the build and package steps.
-rw-r--r--PKGBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e123af9e462f..9cf192f1265d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,15 +24,9 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd orjson
- rm -f "./*.whl" # remove old wheels
-
- PIP_CONFIG_FILE=/dev/null pip wheel --isolated --no-binary=orjson .
-}
-
package() {
cd orjson
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps ./*.whl
install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
+
+ PIP_CONFIG_FILE=/dev/null pip install --root="$pkgdir" --isolated --ignore-installed --no-deps --no-binary=orjson --use-pep517 .
}