summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBigfootACA2021-05-06 02:02:04 +0800
committerBigfootACA2021-05-06 02:02:04 +0800
commit7c8d936c6e30bc34d22bb384b2c431445cc079cc (patch)
treed0cf35b3c11ac0e735551e7f66744a1ef1d92443
parent98f0a52377f5f1821b07340ac9c7190a17e807f3 (diff)
downloadaur-7c8d936c6e30bc34d22bb384b2c431445cc079cc.tar.gz
add documents
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8abb1db6ce90..86fe2c101f2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-oslo-reports
pkgdesc = Oslo Reports library
pkgver = 2.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://docs.openstack.org/oslo.reports/latest/
arch = any
license = Apache
@@ -14,6 +14,10 @@ pkgbase = python-oslo-reports
checkdepends = python-coverage
checkdepends = bandit
makedepends = python-setuptools
+ makedepends = python-sphinx
+ makedepends = python-sphinxcontrib-apidoc
+ makedepends = python-openstackdocstheme
+ makedepends = python-reno
depends = python
depends = python-pbr
depends = python-jinja
diff --git a/PKGBUILD b/PKGBUILD
index ed85f59290e8..de3315d2c256 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@ _pyname=oslo.reports
_pycname=${_pyname/./-}
pkgname=python-${_pycname}
pkgver=2.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Oslo Reports library"
-arch=('any')
+arch=(any)
url="https://docs.openstack.org/oslo.reports/latest/"
-license=('Apache')
+license=(Apache)
depends=(
python
python-pbr
@@ -19,7 +19,13 @@ depends=(
python-oslo-i18n
python-oslo-utils
)
-makedepends=(python-setuptools)
+makedepends=(
+ python-setuptools
+ python-sphinx
+ python-sphinxcontrib-apidoc
+ python-openstackdocstheme
+ python-reno
+)
checkdepends=(
python-hacking
python-oslotest
@@ -40,7 +46,9 @@ export PBR_VERSION=$pkgver
build(){
cd $_pyname-$pkgver
+ export PYTHONPATH="$PWD"
python setup.py build
+ sphinx-build -b text doc/source doc/build/text
}
check(){
@@ -51,4 +59,8 @@ check(){
package(){
cd $_pyname-$pkgver
python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ mkdir -p "$pkgdir/usr/share/doc"
+ cp -r doc/build/text "$pkgdir/usr/share/doc/$pkgname"
+ rm -r "$pkgdir/usr/share/doc/$pkgname/.doctrees"
}