summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-11-18 16:01:48 +1300
committercaltlgin2020-11-18 16:01:48 +1300
commit7b8a9201aeca0800a1ee57df3c5158b0e57ec13a (patch)
treee07610b64fdd62a874bb9c42e5b93193ec92b19c
parent24bc3b5126d011a9215bb2328b88305740382b55 (diff)
downloadaur-7b8a9201aeca0800a1ee57df3c5158b0e57ec13a.tar.gz
Update to v0.16.2
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD10
3 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cbbab69795d..f14380ffc5b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-osmnx
pkgdesc = Retrieve, model, analyze, and visualize OpenStreetMap street networks and other spatial data
- pkgver = 0.16.1
+ pkgver = 0.16.2
pkgrel = 1
url = https://github.com/gboeing/osmnx
arch = any
@@ -20,9 +20,8 @@ pkgbase = python-osmnx
depends = python-scikit-learn
depends = python-scipy
depends = python-shapely
- provides = osmnx
- source = https://files.pythonhosted.org/packages/source/o/osmnx/osmnx-0.16.1.tar.gz
- sha256sums = 92b12a5a15e77eaa0e9822e1ebcb323eb8603257978c1fd394f9f33f508e59b3
+ source = https://files.pythonhosted.org/packages/source/o/osmnx/osmnx-0.16.2.tar.gz
+ sha256sums = 45c94896ca068653b2c233db459d03d8070a813df6cd8d95143f0714f8e0e7d6
pkgname = python-osmnx
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4367ae4a50ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index ccd1fd92525d..01ebe58c0636 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,12 @@
_pkgname='osmnx'
pkgname="python-${_pkgname}"
-pkgver=0.16.1
+pkgver=0.16.2
pkgrel=1
pkgdesc='Retrieve, model, analyze, and visualize OpenStreetMap street networks and other spatial data'
arch=('any')
url='https://github.com/gboeing/osmnx'
+_url_pypi='https://pypi.org/project/osmnx'
license=('MIT')
depends=('python'
'python-descartes'
@@ -25,9 +26,8 @@ depends=('python'
'python-scipy'
'python-shapely')
makedepends=('python-setuptools')
-provides=("${_pkgname}")
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('92b12a5a15e77eaa0e9822e1ebcb323eb8603257978c1fd394f9f33f508e59b3')
+sha256sums=('45c94896ca068653b2c233db459d03d8070a813df6cd8d95143f0714f8e0e7d6')
build() {
cd "${_pkgname}-${pkgver}"
@@ -37,8 +37,8 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
- install -Dm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim: ts=2 sw=2 et: