summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiklas Böhm2023-08-09 11:12:47 +0200
committerNiklas Böhm2023-08-09 11:12:47 +0200
commit89c2a78ba07290cbe3e6f869c66bfdb5775e20ec (patch)
tree537b015e8f083eef72df3e7075756425c987db36
parentf13841bbdb2aa7603704951b1058ad4c29d1742d (diff)
downloadaur-89c2a78ba07290cbe3e6f869c66bfdb5775e20ec.tar.gz
Update to version 1.6.0
Changes the build system to pyproject.toml style Also update dependencies, which have been simplified: https://github.com/gboeing/osmnx/issues/978
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
2 files changed, 32 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c0723bb6600..faf04a195030 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,26 @@
pkgbase = python-osmnx
pkgdesc = Retrieve, model, analyze, and visualize OpenStreetMap street networks and other spatial data
- pkgver = 1.2.2
+ pkgver = 1.6.0
pkgrel = 1
url = https://github.com/gboeing/osmnx
arch = any
license = MIT
- makedepends = python-setuptools
- depends = python-descartes
- depends = python-folium
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-hatchling
depends = python-geopandas
- depends = python-matplotlib
depends = python-networkx
depends = python-numpy
depends = python-pandas
- depends = python-pyproj
depends = python-requests
- depends = python-rtree
- depends = python-scikit-learn
- depends = python-scipy
depends = python-shapely
- source = https://files.pythonhosted.org/packages/source/o/osmnx/osmnx-1.2.2.tar.gz
- sha256sums = 30924452ca02758ece3301f9fcfb1b80edf31e2be7abe7fa7e0fefddb5050408
+ optdepends = python-matplotlib: for visualization
+ optdepends = python-scipy: for entropy
+ optdepends = python-scikit-learn: for neighbors
+ optdepends = python-gdal: for rasterization
+ optdepends = python-rasterio: for rasterization
+ source = https://files.pythonhosted.org/packages/source/o/osmnx/osmnx-1.6.0.tar.gz
+ sha256sums = 719c4dc00c2b489ea9e71a382b9e032721db462d9955edbbf740cd799d93feb3
pkgname = python-osmnx
diff --git a/PKGBUILD b/PKGBUILD
index e03388a9bf4d..67111a212356 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,38 +5,40 @@
_pkgname='osmnx'
pkgname="python-${_pkgname}"
-pkgver=1.2.2
+pkgver=1.6.0
pkgrel=1
pkgdesc='Retrieve, model, analyze, and visualize OpenStreetMap street networks and other spatial data'
arch=('any')
url='https://github.com/gboeing/osmnx'
_url_pypi='https://pypi.org/project/osmnx'
license=('MIT')
-depends=('python-descartes'
- 'python-folium'
- 'python-geopandas'
- 'python-matplotlib'
- 'python-networkx'
- 'python-numpy'
- 'python-pandas'
- 'python-pyproj'
- 'python-requests'
- 'python-rtree'
- 'python-scikit-learn'
- 'python-scipy'
- 'python-shapely')
-makedepends=('python-setuptools')
+depends=(
+ 'python-geopandas'
+ 'python-networkx'
+ 'python-numpy'
+ 'python-pandas'
+ 'python-requests'
+ 'python-shapely'
+)
+optdepends=(
+ 'python-matplotlib: for visualization'
+ 'python-scipy: for entropy'
+ 'python-scikit-learn: for neighbors'
+ 'python-gdal: for rasterization'
+ 'python-rasterio: for rasterization'
+)
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-hatchling')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('30924452ca02758ece3301f9fcfb1b80edf31e2be7abe7fa7e0fefddb5050408')
+sha256sums=('719c4dc00c2b489ea9e71a382b9e032721db462d9955edbbf740cd799d93feb3')
build() {
cd "${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dvm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}