summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2021-01-03 12:59:31 +0100
committerJose Riha2021-01-03 13:00:15 +0100
commit4a2e2eb6f747560be7755901e5eb705950d4f0ed (patch)
tree69e0a1619b24afabfbcca21da7ef93327cebda67
parent6906278fd69e99326c665a135da04c542e205ad3 (diff)
downloadaur-4a2e2eb6f747560be7755901e5eb705950d4f0ed.tar.gz
Add license
-rw-r--r--.SRCINFO4
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD9
3 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37f2fb445119..899701fec1b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-outdated
pkgdesc = Check if a version of a PyPI package is outdated
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/alexmojaki/outdated
arch = any
license = MIT
makedepends = python-setuptools
depends = python
source = https://files.pythonhosted.org/packages/source/o/outdated/outdated-0.2.0.tar.gz
+ source = LICENSE
sha256sums = bcb145e0e372ba467e998c327d3d1ba72a134b0d5a729749729df6c6244ce643
+ sha256sums = dfe14f8798c400cbcc85bb4536a686c6fcf3086b3446c3f7c7054a2bcd73ca6a
pkgname = python-outdated
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..0d4d9dc6c6ce
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2018 Alex Hall
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 57046e6cb368..270b8ae213f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,17 @@
pkgname=python-outdated
_module='outdated'
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Check if a version of a PyPI package is outdated"
url="https://github.com/alexmojaki/outdated"
depends=('python')
makedepends=('python-setuptools')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('bcb145e0e372ba467e998c327d3d1ba72a134b0d5a729749729df6c6244ce643')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz"
+ "LICENSE")
+sha256sums=('bcb145e0e372ba467e998c327d3d1ba72a134b0d5a729749729df6c6244ce643'
+ 'dfe14f8798c400cbcc85bb4536a686c6fcf3086b3446c3f7c7054a2bcd73ca6a')
build() {
cd "${srcdir}/${_module}-${pkgver}"
@@ -21,4 +23,5 @@ build() {
package() {
cd "${srcdir}/${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}