summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-01-14 17:28:52 +0100
committerCarl Smedstad2024-01-14 17:45:28 +0100
commit9a49e43bcad4b10dd24709b65648bc1b14fab1c3 (patch)
tree52780da3f9ad1c0ee466ec2ead9ef7570f41c6eb
parentb9cf0aeb4ba77e78570bbd61a0479e4ee16fd9d1 (diff)
downloadaur-9a49e43bcad4b10dd24709b65648bc1b14fab1c3.tar.gz
upgpkg: python-outlines 0.0.24-1
upstream release
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD40
2 files changed, 37 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d54ca3a8ddbf..b40ff57b24cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-outlines
pkgdesc = Guided text generation
- pkgver = 0.0.23
+ pkgver = 0.0.24
pkgrel = 1
url = https://github.com/outlines-dev/outlines
arch = any
@@ -12,6 +12,8 @@ pkgbase = python-outlines
makedepends = python-setuptools-scm
makedepends = python-wheel
depends = python
+ depends = python-cloudpickle
+ depends = python-diskcache
depends = python-fastapi
depends = python-interegular
depends = python-jinja
@@ -21,15 +23,16 @@ pkgbase = python-outlines
depends = python-numba
depends = python-numpy
depends = python-openai
- depends = python-perscache
depends = python-pydantic
depends = python-pytorch
depends = python-referencing
depends = python-requests
+ depends = python-tiktoken
depends = python-transformers
- source = python-outlines-0.0.23.tar.gz::https://github.com/outlines-dev/outlines/archive/refs/tags/0.0.23.tar.gz
+ optdepends = python-llama-cpp: llama.cpp backend
+ source = python-outlines-0.0.24.tar.gz::https://github.com/outlines-dev/outlines/archive/refs/tags/0.0.24.tar.gz
source = fix-package-discovery.patch
- sha256sums = 094f63276f7920b5424d43f3b394a4692dde6c4b4ead6cd3b9cf13b0eba3cf6c
+ sha256sums = b50e083a86e021edb6d32800ea0334250489980577880272b8c79df15b7e203e
sha256sums = 9140b5e8436f3f75b02f74f6dabb3862f21e93e16c87e6d9a9e6209ec53a8756
pkgname = python-outlines
diff --git a/PKGBUILD b/PKGBUILD
index d71ded019686..507e46a70ef7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-outlines
_name=${pkgname#python-}
-pkgver=0.0.23
+pkgver=0.0.24
pkgrel=1
pkgdesc="Guided text generation"
arch=(any)
@@ -10,6 +10,8 @@ url="https://github.com/outlines-dev/outlines"
license=(Apache)
depends=(
python
+ python-cloudpickle
+ python-diskcache
python-fastapi
python-interegular
python-jinja
@@ -19,11 +21,11 @@ depends=(
python-numba
python-numpy
python-openai
- python-perscache
python-pydantic
python-pytorch
python-referencing
python-requests
+ python-tiktoken
python-transformers
)
makedepends=(
@@ -36,13 +38,16 @@ checkdepends=(
python-pytest
python-responses
)
+optdepends=(
+ 'python-llama-cpp: llama.cpp backend'
+)
source=(
"$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
"fix-package-discovery.patch"
)
sha256sums=(
- '094f63276f7920b5424d43f3b394a4692dde6c4b4ead6cd3b9cf13b0eba3cf6c'
+ 'b50e083a86e021edb6d32800ea0334250489980577880272b8c79df15b7e203e'
'9140b5e8436f3f75b02f74f6dabb3862f21e93e16c87e6d9a9e6209ec53a8756'
)
@@ -64,14 +69,29 @@ build() {
check() {
cd "$_archive"
- # Tests fail due to the following import error:
- # ImportError: /usr/lib/python3.11/site-packages/tokenizers/tokenizers.cpython-311-x86_64-linux-gnu.so: undefined symbol: OnigDefaultSyntax
+ _ignored_tests=(
+ # Fails due to the following import error:
+ # ImportError: /usr/lib/python3.11/site-packages/tokenizers/tokenizers.cpython-311-x86_64-linux-gnu.so: undefined symbol: OnigDefaultSyntax
+ tests/models/test_transformers.py
+ tests/generate/test_integration_transfomers.py
+
+ # Requires python-llama-cpp which I'm currently unable to install.
+ tests/models/test_llama_cpp.py
+ )
+ _ignored_tests_arg=$(printf " --ignore=%s" "${_ignored_tests[@]}")
+
+ _deselected_tests=(
+ # Fails due to the following import error:
+ # ImportError: /usr/lib/python3.11/site-packages/tokenizers/tokenizers.cpython-311-x86_64-linux-gnu.so: undefined symbol: OnigDefaultSyntax
+ tests/test_function.py::test_function_basic
+ tests/fsm/test_regex.py::test_create_fsm_index_tokenizer
+ )
+ _deselected_tests_arg=$(printf " --deselect=%s" "${_deselected_tests[@]}")
+
+ # shellcheck disable=SC2086
pytest \
- --ignore tests/models/test_llama_cpp.py \
- --ignore tests/models/test_transformers.py \
- --ignore tests/generate/test_integration_transfomers.py \
- --deselect tests/test_function.py::test_function_basic \
- --deselect tests/fsm/test_regex.py::test_create_fsm_index_tokenizer
+ $_ignored_tests_arg \
+ $_deselected_tests_arg
}
package() {