summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-03 22:54:43 +1100
committerPumpkinCheshire2020-11-03 22:54:43 +1100
commite659b40c3a9146f333198cb95eaf62bb0f43c85b (patch)
treecc8bdddec57b5a157ded73f14af0a022c3766927
downloadaur-e659b40c3a9146f333198cb95eaf62bb0f43c85b.tar.gz
first build
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29169dea638e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-overly
+ pkgdesc = An overly configurable http server for client testing.
+ pkgver = 0.1.85
+ pkgrel = 1
+ url = https://github.com/theelous3/overly
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-sansio-multipart
+ depends = python-h11
+ source = https://files.pythonhosted.org/packages/source/o/overly/overly-0.1.85.tar.gz
+ sha256sums = 20a99526c7859acc859e87afd97b5c4916405e7477834f727b49210e478370cb
+
+pkgname = python-overly
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94c05018483c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: pumpkincheshire <sollyonzou at gmail dot com>
+
+_name=overly
+pkgname=python-overly
+pkgver=0.1.85
+pkgrel=1
+pkgdesc="An overly configurable http server for client testing."
+arch=('any')
+url="https://github.com/theelous3/overly"
+license=('MIT')
+depends=('python-sansio-multipart' 'python-h11')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('20a99526c7859acc859e87afd97b5c4916405e7477834f727b49210e478370cb')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENCE -t "$pkgdir/usr/share/licenses/$pkgname"
+}
+