summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Rudolph2017-08-21 17:51:32 +0200
committerMichael Rudolph2017-08-21 17:51:32 +0200
commit0693a5832518660ef07565a1ae824c9ee4517fa7 (patch)
tree6b176c765a9a849a5a0cc81f34875e4a96fde0ba
downloadaur-0693a5832518660ef07565a1ae824c9ee4517fa7.tar.gz
initial version 0.4.7
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63b1e0fcda57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-ovh
+ pkgdesc = Official OVH.com API wrapper
+ pkgver = 0.4.7
+ pkgrel = 1
+ url = https://api.ovh.com
+ arch = x86_64
+ license = custom
+ makedepends = python
+ makedepends = python-pip
+
+pkgname = python-ovh
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..92a90cfc4cab
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar
+*~ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16902389655f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ebiadsu <ebiadsu@posteo.de>
+_pipname=ovh
+pkgname=python-${_pipname}
+pkgver=0.4.7
+pkgrel=1
+pkgdesc="Official OVH.com API wrapper"
+arch=("x86_64")
+url="https://api.ovh.com"
+license=('custom')
+makedepends=("python" "python-pip")
+
+prepare() {
+ # manual download to get LICENSE file
+ pip download ${_pipname}
+ cd $srcdir
+ tar -xvzf ${_pipname}-$pkgver.tar.gz ${_pipname}-$pkgver/LICENSE
+}
+
+build() {
+ pip install --no-deps --target="${_pipname}" ${_pipname}
+}
+
+package() {
+ mkdir -p $pkgdir/usr/lib/python3.6/site-packages/
+ cp -r $srcdir/${_pipname}/* $pkgdir/usr/lib/python3.6/site-packages/
+
+ # install license file
+ install -Dm644 ${_pipname}-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}