summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyrilWaechter2022-12-14 03:27:32 +0100
committerCyrilWaechter2022-12-14 03:27:32 +0100
commit9764e9ac2d6f6329a8684168b02b260b3a3d5a89 (patch)
tree3f630cf05a9a4f779949668fe9ad92ef54c0b96d
downloadaur-9764e9ac2d6f6329a8684168b02b260b3a3d5a89.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b0af7b41016
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-owlrl
+ pkgdesc = OWL-RL and RDFS based RDF Closure inferencing for Python
+ pkgver = 6.0.2
+ pkgrel = 1
+ url = https://github.com/RDFLib/OWL-RL/
+ arch = x86_64
+ license = W3C
+ makedepends = python-setuptools
+ depends = python-rdflib
+ provides = python-owlrl
+ source = https://files.pythonhosted.org/packages/source/o/owlrl/owlrl-6.0.2.tar.gz
+ md5sums = 034f9262901fb82761ba5337bbfa0445
+
+pkgname = python-owlrl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5729e7f5713c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Cyril <cyrwae[at]hotmail[dot]com>
+pkgname=python-owlrl
+_name=${pkgname#python-}
+pkgver=6.0.2
+pkgrel=1
+pkgdesc="OWL-RL and RDFS based RDF Closure inferencing for Python"
+arch=('x86_64')
+url="https://github.com/RDFLib/OWL-RL/"
+license=('W3C')
+groups=()
+depends=('python-rdflib')
+makedepends=('python-setuptools')
+optdepends=()
+provides=('python-owlrl')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
+noextract=()
+md5sums=('034f9262901fb82761ba5337bbfa0445')
+
+build() {
+ cd "${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}