summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorteza NourelahiAlamdari2021-05-22 12:55:39 +0200
committerMorteza NourelahiAlamdari2021-05-22 13:03:00 +0200
commit03e63395ef786501710e9748479fb9f138a0df11 (patch)
treef08c28bfc1c9978d9d75e40b4684a201a610a84f
parent2c9a31328b7e9d00f8577946c7fd60b5b3eee091 (diff)
downloadaur-03e63395ef786501710e9748479fb9f138a0df11.tar.gz
Add python-oyaml package
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fe0c33b20f3..20b5a4c2d244 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-oyaml
pkgdesc = Ordered YAML: drop-in replacement for PyYAML which preserves dict ordering
pkgver = 1.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/wimglenn/oyaml
arch = any
license = MIT
makedepends = python-setuptools
- depends = python-pyaml
- source = https://files.pythonhosted.org/packages/source/o/oyaml/oyaml-1.0.tar.gz
- sha256sums = ed8fc096811f4763e1907dce29c35895d6d5936c4d0400fe843a91133d4744ed
+ depends = python-yaml
+ source = https://github.com/wimglenn/oyaml/archive/refs/tags/v1.0.tar.gz
+ sha256sums = 9b49953ab13e1db45126b82264941a4b1630d2bf5c3c56c8b9d12bff2708dac1
pkgname = python-oyaml
diff --git a/PKGBUILD b/PKGBUILD
index b05389c9bce0..dd53a36ba4f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: Morteza NourelahiAlamdari <m@0t1.me>
+# Contributer: Caltlgin Stsodaat <contact@fossdaily.xyz>
_pkgname='oyaml'
-pkgname="python-${_pkgname}"
-pkgver=1.0
-pkgrel=2
-pkgdesc='Ordered YAML: drop-in replacement for PyYAML which preserves dict ordering'
-arch=('any')
-url='https://github.com/wimglenn/oyaml'
-_url_pypi='https://pypi.org/project/oyaml'
-license=('MIT')
-depends=('python-pyaml')
+pkgname="python-oyaml"
+pkgver="1.0"
+pkgrel=3
+pkgdesc="Ordered YAML: drop-in replacement for PyYAML which preserves dict ordering"
+arch=("any")
+url="https://github.com/wimglenn/${_pkgname}"
+source=("${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=("9b49953ab13e1db45126b82264941a4b1630d2bf5c3c56c8b9d12bff2708dac1")
+license=("MIT")
+depends=("python-yaml")
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('ed8fc096811f4763e1907dce29c35895d6d5936c4d0400fe843a91133d4744ed')
build() {
cd "${_pkgname}-${pkgver}"
@@ -25,5 +25,3 @@ package() {
install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-
-# vim: ts=2 sw=2 et: