summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 09:09:38 +1300
committercaltlgin2020-12-03 09:09:38 +1300
commit2c9a31328b7e9d00f8577946c7fd60b5b3eee091 (patch)
treefb849949ecda72ca4b2ec8006feafdb9f7615c2e
parent5597aca81bbe86a8a43ae15a5633496f8d4b5ed3 (diff)
downloadaur-2c9a31328b7e9d00f8577946c7fd60b5b3eee091.tar.gz
Python 3.9 rebuild
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD10
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21e49c25f961..6fe0c33b20f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = python-oyaml
pkgdesc = Ordered YAML: drop-in replacement for PyYAML which preserves dict ordering
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/wimglenn/oyaml
arch = any
license = MIT
makedepends = python-setuptools
- depends = python
depends = python-pyaml
- provides = oyaml
source = https://files.pythonhosted.org/packages/source/o/oyaml/oyaml-1.0.tar.gz
sha256sums = ed8fc096811f4763e1907dce29c35895d6d5936c4d0400fe843a91133d4744ed
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 88dc5730ddbd..b05389c9bce0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_pkgname='oyaml'
pkgname="python-${_pkgname}"
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Ordered YAML: drop-in replacement for PyYAML which preserves dict ordering'
arch=('any')
url='https://github.com/wimglenn/oyaml'
+_url_pypi='https://pypi.org/project/oyaml'
license=('MIT')
-depends=('python' 'python-pyaml')
+depends=('python-pyaml')
makedepends=('python-setuptools')
-provides=("${_pkgname}")
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('ed8fc096811f4763e1907dce29c35895d6d5936c4d0400fe843a91133d4744ed')
@@ -22,8 +22,8 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.rst'
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" 'LICENSE'
+ install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: