summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-12-10 20:55:26 +0100
committerM0Rf302019-12-10 20:55:26 +0100
commit267c2ab277e19606f7de504c272f185df92d9067 (patch)
tree76764e4ad89667c5363e260bb68cc2319447be27
downloadaur-267c2ab277e19606f7de504c272f185df92d9067.tar.gz
python-pa-ringbuffer: 0.1.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c0e6b4418ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pa-ringbuffer
+ pkgdesc = Python wrapper for PortAudio's ring buffer
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/spatialaudio/python-pa-ringbuffer
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = portaudio
+ source = https://github.com/spatialaudio/python-pa-ringbuffer/archive/0.1.3.tar.gz
+ sha256sums = ab4bebceaac4278bca8116a9884d24f6c7714d5db57ddc3a61aad5a2a4407808
+
+pkgname = python-pa-ringbuffer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8df7bd0a8d1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: robertfoster
+
+pkgname=python-pa-ringbuffer
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Python wrapper for PortAudio's ring buffer"
+arch=(any)
+url="https://github.com/spatialaudio/python-pa-ringbuffer"
+license=('MIT')
+depends=('portaudio')
+makedepends=('python-setuptools')
+source=("https://github.com/spatialaudio/python-pa-ringbuffer/archive/$pkgver.tar.gz")
+
+build() {
+ cd ${pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ python setup.py install --root="$pkgdir" --skip-build
+}
+
+sha256sums=('ab4bebceaac4278bca8116a9884d24f6c7714d5db57ddc3a61aad5a2a4407808')