summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2020-07-11 18:23:30 -0400
committerGI_Jack2020-07-11 18:23:30 -0400
commit62a89d3efd7d4a61e6046418aeabf78b49900518 (patch)
treea30acfea6e50d6b3a6b05caba8f549cf568e3fa6
downloadaur-62a89d3efd7d4a61e6046418aeabf78b49900518.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..252729d61db0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pack-git
+ pkgdesc = Password Analysis and Cracking Kit(python3 fork)
+ pkgver = r48.fd779b2
+ pkgrel = 1
+ url = https://github.com/Hydraze/pack
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python
+ depends = python-pyenchant
+ provides = python-pack-git
+ conflicts = python-pack-git
+ source = python-pack-git::git+https://github.com/Hydraze/pack.git
+ sha256sums = SKIP
+
+pkgname = python-pack-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a71d3671d804
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: GI Jack <GI_Jack@hackermail.com>
+
+pkgname=python-pack-git
+_pkgname=python-pack-git
+pkgver=r48.fd779b2
+pkgrel=1
+pkgdesc="Password Analysis and Cracking Kit(python3 fork)"
+arch=('any')
+url="https://github.com/Hydraze/pack"
+license=('BSD')
+groups=()
+depends=('python' 'python-pyenchant')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/Hydraze/pack.git")
+noextract=()
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+#build() {
+# cd "$srcdir/${pkgname%-VCS}"
+# ./autogen.sh
+# ./configure --prefix=/usr
+# make
+#}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ install -Dm755 maskgen.py "${pkgdir}/usr/bin/maskgen.py"
+ install -Dm755 policygen.py "${pkgdir}/usr/bin/policygen.py"
+ install -Dm755 rulegen.py "${pkgdir}/usr/bin/rulegen.py"
+ install -Dm755 statsgen.py "${pkgdir}/usr/bin/statsgen.py"
+ install -Dm644 README "${pkgdir}/usr/share/${pkgname}/doc/README"
+}